Bug 128226 - mkdir .libs -> directory already exists. when using make -j
Summary: mkdir .libs -> directory already exists. when using make -j
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libtool   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Reed
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-20 13:45 UTC by John Ellson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 20:59:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ellson 2004-07-20 13:45:30 UTC
Description of problem:
Builds (of graphviz, but presumably of other packages too) with "make -j"
produce many "directory already exists" warnings.
The warnings come from libtool generated "mkdir .libs" statements.

Version-Release number of selected component (if applicable):
libtool-1.5.6-4

How reproducible:
100% on dual processor machine

Steps to Reproduce:
1../configure; make
2.
3.
  
Actual results:
multiple "directory already exists" warnings

Expected results:
no such warnings

Additional info:
A fix that works for me is to use mkdir -p


--- ltmain.sh.orig       2004-07-05 23:30:16.000000000 -0400
+++ ltmain.sh    2004-07-20 09:20:52.980481383 -0400
@@ -77,7 +77,7 @@
 default_mode=
 help="Try \`$progname --help' for more information."
 magic="%%%MAGIC variable%%%"
-mkdir="mkdir"
+mkdir="mkdir -p"
 mv="mv -f"
 rm="rm -f"

Comment 1 Daniel Reed 2004-08-02 16:25:47 UTC
The version of libtool embedded in graphviz-1.12 is 1.4.2, not 1.5.6.
Before I move this upstream, would it be possible to re-generate
graphviz using libtool 1.5.6 and check for the same behavior?

Comment 2 John Ellson 2004-08-03 14:59:35 UTC
The problem still exists this morning using graphviz from CVS with
libtool-1.5.6.

If you try it yourself, please disable the workaround for this problem 
by commenting out the line in graphviz/autogen.sh that patches
config/ltmain.sh.

Comment 3 Daniel Reed 2004-08-13 20:59:17 UTC
I have reported this to bug-libtool@gnu.org. Since it is just
cosmetic, I'm going to mark this UPSTREAM and wait for a fix in a
future version.


Note You need to log in before you can comment on or make changes to this bug.