Bug 1282329 - atomic-openshift-installer should give reminder once multiple master specified
atomic-openshift-installer should give reminder once multiple master specified
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Munilla
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 01:51 EST by Gaoyun Pei
Modified: 2016-07-03 20:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: openshift-ansible-3.0.13-1.git.0.5e8c5c7.el7aos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:29:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2493 normal SHIPPED_LIVE Red Hat OpenShift Enterprise bug fix update 2015-11-19 22:08:41 EST

  None (edit)
Description Gaoyun Pei 2015-11-16 01:51:54 EST
Description of problem:
The atomic-openshift-installer doesn't support HA master installation yet, but it provide a way to allow user to specify multiple master right now.

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.0.12-1.git.25.269bbc5.el7aos.noarch

How reproducible:
Always

Steps to Reproduce:
1.[root@openshift-v3 ~]# atomic-openshift-installer install

***Host Configuration***
...
Enter hostname or IP address: []: 192.168.0.121
Will this host be an OpenShift Master? [y/N]: y
Do you want to add additional hosts? [y/N]: y
Enter hostname or IP address: []: 192.168.0.122
Will this host be an OpenShift Master? [y/N]: y
Do you want to add additional hosts? [y/N]: y
Enter hostname or IP address: []: 192.168.0.123
Will this host be an OpenShift Master? [y/N]: y
Do you want to add additional hosts? [y/N]: N

...
TASK: [openshift_master | fail ] ********************************************** 
failed: [192.168.0.121] => {"failed": true}
msg: openshift_master_cluster_method must be set to either 'native' or 'pacemaker' for multi-master installations

FATAL: all hosts have already failed -- aborting



Actual results:
The installer failed to set up a HA master environment.

Expected results:
The installer should give a reminder or warning that it's not supporting HA master installation. Or the installer should keep user from being able to specify multiple master host during the interactive guide.  


Additional info:
Comment 5 Gaoyun Pei 2015-11-17 22:07:10 EST
Verify this bug with atomic-openshift-utils-3.0.13-1.git.0.5e8c5c7.el7aos.noarch, the installer would not prompt the master selection once one master host has been input.

[root@openshift-v3 ~]# atomic-openshift-installer install

...
Enter hostname or IP address: []: 192.168.1.36
Will this host be an OpenShift Master? [y/N]: N
Do you want to add additional hosts? [y/N]: y
Enter hostname or IP address: []: 192.168.1.35
Will this host be an OpenShift Master? [y/N]: y
Do you want to add additional hosts? [y/N]: y
Enter hostname or IP address: []: 192.168.1.34
Do you want to add additional hosts? [y/N]: N
Comment 7 errata-xmlrpc 2015-11-19 18:29:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2493

Note You need to log in before you can comment on or make changes to this bug.