Bug 1282374 - Cannot install mod_ssl with httpd-itk
Cannot install mod_ssl with httpd-itk
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: httpd-itk (Show other bugs)
epel7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 04:06 EST by Nigel Reed
Modified: 2015-11-16 04:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 04:53:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Reed 2015-11-16 04:06:50 EST
Description of problem:
yum install mod_ssl fails dependencies when using httpd-itk rather than httpd

Version-Release number of selected component (if applicable):
# rpm -q httpd-itk
httpd-itk-2.4.7.01-5.el7.x86_64
Name        : mod_ssl
Arch        : x86_64
Epoch       : 1
Version     : 2.4.6
Release     : 31.el7.centos.1

How reproducible:
Every time

Steps to Reproduce:
1. Add epel repo
2. yum install httpd-itk
3. yum install mod_ssl

Actual results:
Resolving Dependencies
--> Running transaction check
---> Package mod_ssl.x86_64 1:2.4.6-31.el7.centos.1 will be installed
--> Processing Dependency: httpd = 2.4.6-31.el7.centos.1 for package: 1:mod_ssl-2.4.6-31.el7.centos.1.x86_64
--> Finished Dependency Resolution
Error: Package: 1:mod_ssl-2.4.6-31.el7.centos.1.x86_64 (updates)
           Requires: httpd = 2.4.6-31.el7.centos.1
           Installed: httpd-2.4.10-7.el7.centos.x86_64 (installed)
               httpd = 2.4.10-7.el7.centos
           Available: httpd-2.4.6-31.el7.centos.x86_64 (base)
               httpd = 2.4.6-31.el7.centos
           Available: httpd-2.4.6-31.el7.centos.1.x86_64 (updates)
               httpd = 2.4.6-31.el7.centos.1
 You could try using --skip-broken to work around the problem


Expected results:
Install should complete

Additional info:
Comment 1 Anssi Johansson 2015-11-16 04:23:56 EST
"Installed: httpd-2.4.10-7.el7.centos.x86_64 (installed)" does not look like a CentOS package to me, despite the centos tag in the name. Perhaps wherever you got the package also provides a matching mod_ssl. "rpm -qi httpd" and/or "yum info httpd" should tell you where you got your httpd. I would try using the official CentOS version of httpd instead of your httpd-2.4.10.
Comment 2 Nigel Reed 2015-11-16 04:35:10 EST

# rpm -qi httpd-itk|egrep "^Packager|^Vendor"
Packager    : Fedora Project
Vendor      : Fedora Project

yumdb search from_repo 'epel' shows
httpd-itk-2.4.7.01-5.el7.x86_64
     from_repo = epel

I believe I recompiled locally from sources to test out a patch. It's been a while.

See also feature request 1059143

This package is definitely in EPEL.
Comment 3 Nigel Reed 2015-11-16 04:36:27 EST
# yum remove httpd-itk
Loaded plugins: changelog, fastestmirror, langpacks
Resolving Dependencies
--> Running transaction check
---> Package httpd-itk.x86_64 0:2.4.7.01-5.el7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================================
 Package                                  Arch                                  Version                                          Repository                            Size
============================================================================================================================================================================
Removing:
 httpd-itk                                x86_64                                2.4.7.01-5.el7                                   @epel
Comment 4 Nigel Reed 2015-11-16 04:42:22 EST
I went ahead and cleared everything httpd related out and reinstalled it and seemed to work including mod_ssl. Not quite sure what got it in a mess. I'll test and close out later.
Comment 5 manuel wolfshant 2015-11-16 04:53:38 EST
Your httpd-2.4.10-7.el7.centos was not compatible with stock mod_ssl ( which comes from the same source package as httpd-2.4.6-31). Therefore you needed to either downgrade httpd to the version supported by CentOS (  2.4.6-31.el7.centos.1 ) or get mod_ssl from the same repository from where httpd-2.4.10-7.el7.centos came.

As a side note, httpd_itk from EPEL works just fine with mod_ssl-:2.4.6-31.el7.centos.1

Note You need to log in before you can comment on or make changes to this bug.