Bug 1282449 - Hosts list under host tab shows previously cluster hosts list.
Hosts list under host tab shows previously cluster hosts list.
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Andrej Krejcir
Israel Pinto
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 08:09 EST by Israel Pinto
Modified: 2016-02-18 06:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:02:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rgolan: ovirt‑3.6.z?
rule-engine: planning_ack?
rgolan: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
engine_log (41.82 KB, application/zip)
2015-11-16 08:09 EST, Israel Pinto
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49022 master MERGED webadmin: Possible to display no elements in ListModelMultipleSelectListBox Never
oVirt gerrit 50539 ovirt-engine-3.6 MERGED webadmin: Possible to display no elements in ListModelMultipleSelectListBox Never

  None (edit)
Description Israel Pinto 2015-11-16 08:09:08 EST
Description of problem:
The hosts list in host tab shows the previously cluster hosts list. 
I have 2 cluster in setup, one with hosts  and the second without hosts
I Edit VM and update form cluster with to cluster without hosts.
In the host tab i see the hosts list from previously cluster.

Version-Release number of selected component (if applicable):
RHEVM: 3.6.0.3-0.1.el6
VDSM:vdsm-4.17.10.1-0.el7ev
libvirt: libvirt-1.2.17-13.el7

How reproducible:
All the time

Steps to Reproduce:
1. Setup with 2 cluster: one with 2 hosts, second without hosts
2. Create vm and start it
3. Stop VM
4. Edit VM, update "Cluster" 
5. Check Host tab under "Specific" list

Actual results:
Shows hosts list from previously cluster.


Expected results:
Empty list since there is no hosts under this cluster

Additional info:
Comment 1 Israel Pinto 2015-11-16 08:09 EST
Created attachment 1094868 [details]
engine_log
Comment 2 Roy Golan 2015-11-17 04:17:29 EST
Seems like the on cluster change event should have triggered a query for the cluster hosts. 

Fix should be easy, low risk.
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-17 04:17:58 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 4 Red Hat Bugzilla Rules Engine 2015-11-17 04:19:28 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 5 Red Hat Bugzilla Rules Engine 2015-12-07 04:36:04 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 6 Red Hat Bugzilla Rules Engine 2015-12-15 07:58:03 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 7 Red Hat Bugzilla Rules Engine 2015-12-15 15:03:36 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 8 Red Hat Bugzilla Rules Engine 2015-12-15 17:13:41 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 9 Red Hat Bugzilla Rules Engine 2015-12-15 17:15:23 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 10 Red Hat Bugzilla Rules Engine 2015-12-15 17:15:23 EST
Fixed bug tickets must have target milestone set prior to fixing them. Please set the correct milestone and move the bugs back to the previous status after this is corrected.
Comment 11 Sandro Bonazzola 2015-12-23 08:41:01 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 12 Israel Pinto 2016-01-17 05:24:59 EST
Verify with:
rhevm-3.6.2-0.1.el6.noarch

Steps to Reproduce:
1. Setup with 3 cluster: one with 2 hosts, second 1 hosts , third without hosts
2. Create vm and start it
3. Stop VM
4. Edit VM, update "Cluster" to cluster without hosts 
5. Check Host tab under "Specific" list no hosts

Results: Pass

Note You need to log in before you can comment on or make changes to this bug.