Bug 128245 - system-config-samba fails with AttributeError
Summary: system-config-samba fails with AttributeError
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-samba
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 133659 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-20 19:00 UTC by Clyde E. Kunkel
Modified: 2012-12-16 17:22 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-07-20 19:10:37 UTC


Attachments (Terms of Use)
requested smb.conf file (10.58 KB, text/plain)
2004-07-20 19:03 UTC, Clyde E. Kunkel
no flags Details

Description Clyde E. Kunkel 2004-07-20 19:00:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
Clicking Samba in Server Settings menu does nothing.  When as root
invoking system-config-samba, the following error is reported:

    raise AttributeError, value
AttributeError: ('cups options', 'raw')

and returns to #


Version-Release number of selected component (if applicable):
1.2.12-1

How reproducible:
Always

Steps to Reproduce:
1.in a terminal window as root type "system-config-samba" and press enter
2.
3.
    

Actual Results:  Received error msg with traceback:
[root@FedoraCore3T1 root]# system-config-samba
Traceback (most recent call last):
  File "/usr/share/system-config-samba/system-config-samba.py", line
38, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/system-config-samba/mainWindow.py", line 75, in
__init__
    self.samba_data = sambaParser.SambaParser(self)
  File "/usr/share/system-config-samba/sambaParser.py", line 40, in
__init__
    self.parseFile()
  File "/usr/share/system-config-samba/sambaParser.py", line 71, in
parseFile
    token = self.createToken(line)
  File "/usr/share/system-config-samba/sambaParser.py", line 143, in
createToken
    token =
sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL, (name,
value), self.parent)
  File "/usr/share/system-config-samba/sambaToken.py", line 36, in
__init__
    raise AttributeError, value
AttributeError: ('cups options', 'raw')


Expected Results:  Samba setup gui should have been presented

Additional info:

ASUS P4C800-E Deluxe

Comment 1 Brent Fox 2004-07-20 19:02:36 UTC
Please attach your /etc/samba/smb.conf file.

Comment 2 Clyde E. Kunkel 2004-07-20 19:03:47 UTC
Created attachment 102076 [details]
requested smb.conf file

file requested by Brent Fox

Comment 3 Brent Fox 2004-07-20 19:10:37 UTC
Should be fixed in system-config-samba-1.2.13-1 in Rawhide once it
gets refreshed.  Thanks for your report.

Comment 4 Nils Philippsen 2004-09-25 21:03:54 UTC
*** Bug 133659 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.