Bug 1282475 - [abrt] general protection fault in kmem_cache_alloc
[abrt] general protection fault in kmem_cache_alloc
Status: CLOSED DUPLICATE of bug 1278561
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:129aaad6cb505f46e072aa1cb7b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 09:26 EST by Vinicius Reis
Modified: 2015-11-17 10:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 10:12:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (68.00 KB, text/plain)
2015-11-16 09:26 EST, Vinicius Reis
no flags Details

  None (edit)
Description Vinicius Reis 2015-11-16 09:26:07 EST
Description of problem:
Just did a cold boot, then system hanged.

Additional info:
reporter:       libreport-2.6.3
general protection fault: 0000 [#1] SMP 
Modules linked in: snd_soc_sst_acpi(+) soundcore dell_rbtn i2c_designware_platform(+) i2c_designware_core int3400_thermal rfkill acpi_thermal_rel lpc_ich nfsd auth_rpcgss nfs_acl lockd grace sunrpc hid_multitouch hid_sensor_hub i915 i2c_algo_bit drm_kms_helper drm serio_raw sdhci_acpi sdhci mmc_core video i2c_hid
CPU: 1 PID: 35 Comm: kdevtmpfs Not tainted 4.2.5-300.fc23.x86_64 #1
Hardware name: Dell Inc. Inspiron 7348/0RTGX8, BIOS A07 07/07/2015
task: ffff880254821d80 ti: ffff88025483c000 task.ti: ffff88025483c000
RIP: 0010:[<ffffffff8120001f>]  [<ffffffff8120001f>] kmem_cache_alloc+0x7f/0x210
RSP: 0000:ffff88025483fb28  EFLAGS: 00010246
RAX: 00ff8802520aeb00 RBX: 0000000000018020 RCX: 0000000000000020
RDX: 000000000000421f RSI: 0000000000018020 RDI: 0000000000019bc0
RBP: ffff88025483fb68 R08: ffff88025ec59bc0 R09: 00ff8802520aeb00
R10: 0000000000000009 R11: 0000000000000100 R12: 0000000000018020
R13: ffff880256003b00 R14: ffffffff81323207 R15: ffff880256003b00
FS:  0000000000000000(0000) GS:ffff88025ec40000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000563ed225b000 CR3: 000000003f910000 CR4: 00000000003406e0
Stack:
 00070005020a04c9 000000008e139f11 ffff88025483fc08 0000000000000046
 0000000000000005 0000000000000025 ffff88025483fc4c 0000000000000001
 ffff88025483fbb8 ffffffff81323207 ffff88025483fc58 0000004681338363
Call Trace:
 [<ffffffff81323207>] avc_alloc_node+0x27/0x120
 [<ffffffff81323364>] avc_compute_av+0x64/0x190
 [<ffffffff813239b2>] avc_has_perm+0x122/0x190
 [<ffffffff8132594c>] may_create+0xfc/0x110
 [<ffffffff813259a2>] selinux_inode_mknod+0x42/0x80
 [<ffffffff81320186>] security_inode_mknod+0x56/0x80
 [<ffffffff8122a77d>] vfs_mknod+0xcd/0x160
 [<ffffffff814d6c89>] handle_create+0x89/0x220
 [<ffffffff81774b31>] ? __schedule+0x371/0x950
 [<ffffffff814d6f52>] devtmpfsd+0x132/0x160
 [<ffffffff814d6e20>] ? handle_create+0x220/0x220
 [<ffffffff810bc8b8>] kthread+0xd8/0xf0
 [<ffffffff810bc7e0>] ? kthread_worker_fn+0x160/0x160
 [<ffffffff817795df>] ret_from_fork+0x3f/0x70
 [<ffffffff810bc7e0>] ? kthread_worker_fn+0x160/0x160
Code: 83 78 10 00 4d 8b 08 0f 84 37 01 00 00 4d 85 c9 0f 84 2e 01 00 00 49 63 45 20 49 8b 7d 00 4c 01 c8 40 f6 c7 0f 0f 85 60 01 00 00 <48> 8b 18 48 8d 4a 01 4c 89 c8 65 48 0f c7 0f 0f 94 c0 84 c0 74 
RIP  [<ffffffff8120001f>] kmem_cache_alloc+0x7f/0x210
 RSP <ffff88025483fb28>
Comment 1 Vinicius Reis 2015-11-16 09:26:18 EST
Created attachment 1094944 [details]
File: dmesg
Comment 2 Vinicius Reis 2015-11-16 09:33:02 EST
It's still happening (apparently) randomly in both 4.2.3 and 4.2.5 kernels at *boot time*. Once the system is booted up (sometimes it's really hard to achieve), the system works fine.
I've also attached the URL for the 4.2.3 issue.
Comment 3 Josh Boyer 2015-11-17 10:12:07 EST

*** This bug has been marked as a duplicate of bug 1278561 ***

Note You need to log in before you can comment on or make changes to this bug.