Bug 1282505 - python-astroid-1.3.7-2.fc24 FTBFS: tests fail
python-astroid-1.3.7-2.fc24 FTBFS: tests fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-astroid (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 1287055 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 10:45 EST by Petr Pisar
Modified: 2016-04-27 17:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-astroid-1.4.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-27 17:49:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-11-16 10:45:10 EST
python-astroid-1.3.7-2.fc24 fails to build in F24 because tests fail

+ pushd /builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24
+ /usr/bin/python3 setup.py test
~/build/BUILD/python3-python-astroid-1.3.7-2.fc24 ~/build/BUILD/logilab-astroid-cda2deee65e3
running test
running egg_info
writing top-level names to astroid.egg-info/top_level.txt
writing dependency_links to astroid.egg-info/dependency_links.txt
writing astroid.egg-info/PKG-INFO
writing requirements to astroid.egg-info/requires.txt
reading manifest file 'astroid.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
writing manifest file 'astroid.egg-info/SOURCES.txt'
running build_ext
Traceback (most recent call last):
  File "setup.py", line 59, in <module>
    install()
  File "setup.py", line 54, in install
    cmdclass={'install_lib': AstroidInstallLib}
  File "/usr/lib64/python3.5/distutils/core.py", line 148, in setup
    dist.run_commands()
  File "/usr/lib64/python3.5/distutils/dist.py", line 955, in run_commands
    self.run_command(cmd)
  File "/usr/lib64/python3.5/distutils/dist.py", line 974, in run_command
    cmd_obj.run()
  File "/usr/lib/python3.5/site-packages/setuptools/command/test.py", line 152, in run
    self.with_project_on_sys_path(self.run_tests)
  File "/usr/lib/python3.5/site-packages/setuptools/command/test.py", line 133, in with_project_on_sys_path
    func()
  File "/usr/lib/python3.5/site-packages/setuptools/command/test.py", line 173, in run_tests
    testRunner=self._resolve_as_ep(self.test_runner),
  File "/usr/lib64/python3.5/unittest/main.py", line 93, in __init__
    self.parseArgs(argv)
  File "/usr/lib64/python3.5/unittest/main.py", line 123, in parseArgs
    self._do_discovery([])
  File "/usr/lib64/python3.5/unittest/main.py", line 228, in _do_discovery
    self.test = loader.discover(self.start, self.pattern, self.top)
  File "/usr/lib64/python3.5/unittest/loader.py", line 341, in discover
    tests = list(self._find_tests(start_dir, pattern))
  File "/usr/lib64/python3.5/unittest/loader.py", line 398, in _find_tests
    full_path, pattern, namespace)
  File "/usr/lib64/python3.5/unittest/loader.py", line 475, in _find_test_path
    tests = self.loadTestsFromModule(package, pattern=pattern)
  File "/usr/lib/python3.5/site-packages/setuptools/command/test.py", line 36, in loadTestsFromModule
    tests.append(self.loadTestsFromName(submodule))
  File "/usr/lib64/python3.5/unittest/loader.py", line 190, in loadTestsFromName
    return self.loadTestsFromModule(obj)
  File "/usr/lib/python3.5/site-packages/setuptools/command/test.py", line 36, in loadTestsFromModule
    tests.append(self.loadTestsFromName(submodule))
  File "/usr/lib64/python3.5/unittest/loader.py", line 153, in loadTestsFromName
    module = __import__(module_name)
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/tests/unittest_inference.py", line 69, in <module>
    class InferenceTest(resources.SysPathSetup, unittest.TestCase):
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/tests/unittest_inference.py", line 121, in InferenceTest
    ast = test_utils.build_module(CODE, __name__)
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/test_utils.py", line 186, in build_module
    return builder.AstroidBuilder(None).string_build(code, modname=module_name, path=path)
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/builder.py", line 139, in string_build
    module = self._data_build(data, modname, path)
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/builder.py", line 177, in _data_build
    module = rebuilder.visit_module(node, modname, node_file, package)
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 148, in visit_module
    newnode.body = [self.visit(child, newnode) for child in node.body]
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 148, in <listcomp>
    newnode.body = [self.visit(child, newnode) for child in node.body]
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 161, in visit
    return self._transform(visit_method(node, parent))
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 915, in visit_class
    newnode = super(TreeRebuilder3k, self).visit_class(node, parent)
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 345, in visit_class
    newnode.body = [self.visit(child, newnode) for child in node.body]
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 345, in <listcomp>
    newnode.body = [self.visit(child, newnode) for child in node.body]
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 161, in visit
    return self._transform(visit_method(node, parent))
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 502, in visit_function
    newnode.body = [self.visit(child, newnode) for child in node.body]
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 502, in <listcomp>
    newnode.body = [self.visit(child, newnode) for child in node.body]
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 161, in visit
    return self._transform(visit_method(node, parent))
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 238, in visit_assign
    newnode.value = self.visit(node.value, newnode)
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 161, in visit
    return self._transform(visit_method(node, parent))
  File "/builddir/build/BUILD/python3-python-astroid-1.3.7-2.fc24/astroid/rebuilder.py", line 331, in visit_callfunc
    if node.starargs is not None:
AttributeError: 'Call' object has no attribute 'starargs'
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.wrh9Cv (%check)
    Bad exit status from /var/tmp/rpm-tmp.wrh9Cv (%check)

This can be caused by recent python3 upgrade to 3.5.0.
Comment 1 Brian Lane 2015-11-16 14:50:42 EST
Upstream is working on it - https://bitbucket.org/logilab/astroid/issues/117/support-python-35
Comment 2 Nils Philippsen 2015-11-30 10:49:41 EST
I just tripped over the python-astroid FTBFS and noticed that astroid 1.4.0/1.4.1 were published meanwhile which should support Python 3.5. If you don't object to it, I'd just build 1.4.1 into Rawhide.
Comment 3 Nils Philippsen 2015-11-30 11:21:26 EST
As discussed, you'll do build and tests.
Comment 4 Brian Lane 2015-12-01 17:13:19 EST
*** Bug 1287055 has been marked as a duplicate of this bug. ***
Comment 5 Brian Lane 2015-12-01 17:16:26 EST
pylint 1.5 and astroid 1.4.1 require a new package, lazy-object-proxy, which I'm woking on packaging. Even with the new package installed I'm getting other errors when trying to use pylint on the Anaconda source tree so it's going to be a while before this is resolved.
Comment 6 Jan Kurik 2016-02-24 08:59:01 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.