Bug 1282541 - authentication_userid/authentication_password methods missing for Foreman provider
authentication_userid/authentication_password methods missing for Foreman pro...
Status: CLOSED DUPLICATE of bug 1282537
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 12:12 EST by ncatling
Modified: 2015-11-16 12:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 12:14:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ncatling 2015-11-16 12:12:46 EST
Description of problem:

authentication_userid/authentication_password methods missing for Foreman/Configuration Manager provider. Following error produced:

NoMethodError: undefined method `authentication_userid' for #<MiqAeMethodService::MiqAeServiceProvisioningManagerForeman:0x000000075d0320>


Version-Release number of selected component (if applicable):

5.4.3.1


How reproducible:


Steps to Reproduce:
1. Add Satellite 6 provider
2. Access rails console
3. Execute following: $evm.vmdb('ext_management_system').all.each { |ems| puts ems.authentication_userid }

Actual results:

irb(main):022:0> $evm.vmdb('ext_management_system').all.each { |ems| puts ems.authentication_userid }
  ExtManagementSystem Load (0.3ms)  SELECT "ext_management_systems".* FROM "ext_management_systems" 
  ExtManagementSystem Inst Including Associations (0.9ms - 9rows)
  Authentication Load (0.3ms)  SELECT "authentications".* FROM "authentications" WHERE "authentications"."resource_id" = 1000000000006 AND "authentications"."resource_type" = 'ExtManagementSystem'
  Authentication Inst Including Associations (0.1ms - 1rows)
admin
  Authentication Load (0.2ms)  SELECT "authentications".* FROM "authentications" WHERE "authentications"."resource_id" = 1000000000007 AND "authentications"."resource_type" = 'ExtManagementSystem'
  Authentication Inst Including Associations (0.2ms - 3rows)
admin
  Authentication Load (0.2ms)  SELECT "authentications".* FROM "authentications" WHERE "authentications"."resource_id" = 1000000000009 AND "authentications"."resource_type" = 'ExtManagementSystem'
  Authentication Inst Including Associations (0.1ms - 2rows)
admin@internal
NoMethodError: undefined method `authentication_userid' for #<MiqAeMethodService::MiqAeServiceProvisioningManagerForeman:0x000000075d0320>
	from /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:176:in `method_missing'
	from (irb):22:in `block in irb_binding'
	from (irb):22:in `each'
	from (irb):22
	from /opt/rh/cfme-gemset/bundler/gems/rails-4842a8377644/railties/lib/rails/commands/console.rb:47:in `start'
	from /opt/rh/cfme-gemset/bundler/gems/rails-4842a8377644/railties/lib/rails/commands/console.rb:8:in `start'
	from /opt/rh/cfme-gemset/bundler/gems/rails-4842a8377644/railties/lib/rails/commands.rb:41:in `<top (required)>'
	from script/rails:6:in `require'
	from script/rails:6:in `<main>'



Expected results:

authentication_userid/authentication_password should be displayed.

Additional info:
Comment 2 ncatling 2015-11-16 12:14:40 EST

*** This bug has been marked as a duplicate of bug 1282537 ***

Note You need to log in before you can comment on or make changes to this bug.