Bug 1282549 - vmware store has wrong imports to oslo_ packages
vmware store has wrong imports to oslo_ packages
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glance-store (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 6.0 (Juno)
Assigned To: Flavio Percoco
Tzach Shefi
: OtherQA, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 12:37 EST by Flavio Percoco
Modified: 2016-01-14 08:53 EST (History)
5 users (show)

See Also:
Fixed In Version: python-glance-store-0.1.10-6.el7ost
Doc Type: Bug Fix
Doc Text:
A previous backport introduced incompatible import lines that broke the VMware driver in glance-store. With this release, fixed that backport to be compliant with the import lines has now resolved the issue.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 08:53:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Percoco 2015-11-16 12:37:48 EST
A backport made to resolve the bz#1200075 introduced incompatible import lines to the vmware store driver. These import lines try to import from oslo_* packages, whereas the name of these packages as of OSP6 are oslo.*
Comment 2 nlahouti 2015-11-19 12:53:20 EST
(In reply to Flavio Percoco from comment #0)
> A backport made to resolve the bz#1200075 introduced incompatible import
> lines to the vmware store driver. These import lines try to import from
> oslo_* packages, whereas the name of these packages as of OSP6 are oslo.*
Hi Flavio,


How can I apply to my setup? Do I need to reinstall everything from scratch?
Comment 5 errata-xmlrpc 2016-01-14 08:53:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0036.html

Note You need to log in before you can comment on or make changes to this bug.