Bug 1282552 - old pulp pkgs in RHEL6 iso
old pulp pkgs in RHEL6 iso
Status: CLOSED NOTABUG
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHUI Bug List
Martin Minar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 12:46 EST by Irina Gulina
Modified: 2016-07-03 20:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-18 09:52:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Irina Gulina 2015-11-16 12:46:52 EST
Description of problem:

RHEL6 iso of Oct 13th (and for Oct 8th the same):

>> rhui-manager
/usr/lib64/python2.6/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.
  _warn("Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)
Previous authentication credentials could not be found. Logging into
the RHUI.

If this is the first time using the RHUI, it is recommended to change
the user's password in the User Management section of RHUI Tools.

RHUI Username: admin 
RHUI Password: 

Network error, please check the pulp server is available and running


>> less /var/log/messages

pulp.server.async.scheduler:ERROR: [Errno -2] Name or service not known
celery.worker.consumer:ERROR: (29803-89664) consumer: Cannot connect to qpid://guest@rhua.eu-west-1.compute.internal:5671//: [Errno -2] Name or service not known.
There are 0 pulp_resource_manager processes running. 
There are 0 pulp_celerybeat processes running

>> rpm -qa | grep "pulp"
python-pulp-bindings-2.7.0-0.5.beta.el6ui.noarch
pulp-admin-client-2.7.0-0.5.beta.el6ui.noarch
python-isodate-0.5.0-4.pulp.el6ui.noarch
pulp-server-2.7.0-0.5.beta.el6ui.noarch
mod_wsgi-3.4-1.pulp.el6ui.x86_64
python-pulp-oid_validation-2.7.0-0.5.beta.el6ui.noarch
python-pulp-docker-common-1.1.0-0.1.alpha.git.33.70d43d4.el6ui.noarch
python-pulp-client-lib-2.7.0-0.5.beta.el6ui.noarch
python-pulp-common-2.7.0-0.5.beta.el6ui.noarch
python-pulp-repoauth-2.7.0-0.5.beta.el6ui.noarch
pulp-rpm-plugins-2.7.0-0.5.beta.el6ui.noarch
pulp-rpm-admin-extensions-2.7.0-0.5.beta.el6ui.noarch
python-kombu-3.0.24-8.pulp.el6ui.noarch
pulp-selinux-2.7.0-0.5.beta.el6ui.noarch
python-pulp-rpm-common-2.7.0-0.5.beta.el6ui.noarch
pulp-docker-plugins-1.1.0-0.1.alpha.git.33.70d43d4.el6ui.noarch



How reproducible:
always

Steps to Reproduce:
1. with RHEL-6-20151013 (or 20151008) try to login to rhui-manager
2. check /var/log/messages to see pulp errors
3. check installed pulp pkgs

Actual results:
can't login into rhui-manager

Expected results:
successful login into rhui-manager

Note You need to log in before you can comment on or make changes to this bug.