Bug 1282588 - service_request_quota_validation.rb does not report quota message for memory
service_request_quota_validation.rb does not report quota message for memory
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Tina Fitzgerald
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 14:59 EST by Jeffrey Cutter
Modified: 2015-12-21 11:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:02:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Cutter 2015-11-16 14:59:08 EST
Description of problem:

The included service_request_quota_validation.rb in the RedHat domain does not report the quota message for memory back up to the Last Message in the Services -> Requests log.

The method in question is located at:

/RedHat/Service/Provisioning/StateMachines/ServiceProvisionRequestQuotaVerification.class/__methods__/service_request_quota_validation.rb

Diff of updates to resolve issue:

@@ -316,11 +316,11 @@ def quota_exceeded_message(quota_hash, type)
   end
 
   ["group_#{warn}cpu_quota_exceeded".to_sym,
-   "group_#{warn}ram_quota_exceeded".to_sym,
+   "group_#{warn}memory_quota_exceeded".to_sym,
    "group_#{warn}storage_quota_exceeded".to_sym,
    "group_#{warn}vms_quota_exceeded".to_sym,
    "owner_#{warn}cpu_quota_exceeded".to_sym,
-   "owner_#{warn}ram_quota_exceeded".to_sym,
+   "owner_#{warn}memory_quota_exceeded".to_sym,
    "owner_#{warn}storage_quota_exceeded".to_sym,
    "owner_#{warn}vms_quota_exceeded".to_sym].each do |q|
      message += "(#{quota_hash[q]}}) " if quota_hash[q]


Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1.  Setup quotas on your test/user group and tag Quota - Max Memory => 1 GB
2.  Perform a test provision using more than 1 GB.
3.  Review the results on Services -> Request, especially the Last Message after provisioning is denied due to quota.

Actual results:

Last Message: Service request denied due to the following quota limits:

Expected results:

Last Message: Service request denied due to the following quota limits:(Group: EvmGroup-administrator - 20480MB plus requested 0MB > quota 1024MB})

Additional info:
Comment 2 Tina Fitzgerald 2015-12-17 15:00:34 EST
Hi Jeffrey,

The reported issue is resolved in the new consolidated quota. 

Wondering if we can close this or if a fix is required.

Thanks,
Tina
Comment 3 Jeffrey Cutter 2015-12-17 16:25:51 EST
Hi Tina,

Is the new consolidated quota in CloudForms 4 and not 3.2, is that what you mean?

If that is what you mean, I do not personally see a big need to fix it in 3.2 in particular as long as it's fixed moving forward.

Thanks,
-Jeff
Comment 4 Tina Fitzgerald 2015-12-21 11:02:56 EST
The new consolidated quota resolves this issue.

Note You need to log in before you can comment on or make changes to this bug.