Bug 128261 - qla2300.o does not recognize attached tape devices
qla2300.o does not recognize attached tape devices
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-20 18:10 EDT by George McConnell
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-27 16:51:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output from /proc/scsi/scsi (521 bytes, text/plain)
2004-07-20 18:11 EDT, George McConnell
no flags Details
Output of sysreport (452.16 KB, application/x-bzip)
2004-07-20 18:12 EDT, George McConnell
no flags Details
Output from lspci, lsmod, uname -r (1.52 KB, text/plain)
2004-07-20 18:13 EDT, George McConnell
no flags Details

  None (edit)
Description George McConnell 2004-07-20 18:10:05 EDT
Kernel 2.4.21-15.0.3.ELsmp running RHEL 3.0/U2. Using card QLogic 2340.

The qla2300.o does not recognize HP Ultrium LTO drives in the zone. It
recognizes the Medium Changer arm, but does not report the tape drives.


How reproducible:

Always.

Steps to Reproduce:
1. modprobe qla2300

  
Actual results:

dmesg | tail

scsi2 : QLogic QLA2312 PCI to Fibre Channel Host Adapter: bus 19
device 1 irq 29
        Firmware version:  3.02.24, Driver version 6.07.02-RH2

blk: queue f5090418, I/O limit 4294967295Mb (mask 0xffffffffffffffff)
  Vendor: OVERLAND  Model: NEO Series        Rev: 0421
  Type:   Medium Changer                     ANSI SCSI revision: 02
blk: queue f5090618, I/O limit 4294967295Mb (mask 0xffffffffffffffff)
Attached scsi generic sg2 at scsi2, channel 0, id 0, lun 0,  type 8


Expected results:

For three HP Ultrium tape drives to also be recognized.
Comment 1 George McConnell 2004-07-20 18:11:12 EDT
Created attachment 102081 [details]
Output from /proc/scsi/scsi

Output from /proc/scsi/scsi
Comment 2 George McConnell 2004-07-20 18:12:22 EDT
Created attachment 102082 [details]
Output of sysreport

Output of sysreport
Comment 3 George McConnell 2004-07-20 18:13:29 EDT
Created attachment 102083 [details]
Output from lspci, lsmod, uname -r

Output from lspci, lsmod, uname -r
Comment 4 George McConnell 2004-07-27 16:51:08 EDT
I ended up buying a different HBA to resolve this issue.
Comment 5 Tom Coughlan 2004-07-27 17:21:09 EDT
For the record: 

There seems to be an incompatibility between the 6.07.02-RH2 driver
and certain FC switches.  This problem prevents some devices from
being discovered.  The following messages in the log are indicative of
the problem: 

scsi(2) qla2x00_isr MBA_PORT_UPDATE ignored

In at least one case the v7 QLogic driver in RHEL 3 U3 solves this
problem.

Note You need to log in before you can comment on or make changes to this bug.