Bug 1282624 - hamcrest specifically requires java-1.6.0
hamcrest specifically requires java-1.6.0
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hamcrest (Show other bugs)
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Michael Simacek
Branislav Náter
: EasyFix
Depends On: 1184486
  Show dependency treegraph
Reported: 2015-11-16 17:26 EST by Michael Simacek
Modified: 2016-06-28 07:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: hamcrest-1.1-9.5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-05-10 20:14:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Simacek 2015-11-16 17:26:11 EST
Description of problem:
hamcrest has Requires: java-1.6.0, even though it should work with newer versions of java.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. yum -y install java-1.7.0 java-1.7.0-devel
2. yum -y install hamcrest

Actual results:
java-1.6.0-openjdk is installed as a dependency

Expected results:
no java 6 runtime installed

Additional info:
Comment 2 Michael Simacek 2015-12-04 10:04:49 EST
In order to be installable without pulling in JDK 6, junit4 also needs to have its requires adjusted. adding it as a dependency.
Comment 7 errata-xmlrpc 2016-05-10 20:14:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.