Bug 1282742 - man page for command dd excludes useful tip.
man page for command dd excludes useful tip.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 05:09 EST by vikram goyal
Modified: 2015-11-17 07:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-17 07:11:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vikram goyal 2015-11-17 05:09:42 EST
Description of problem:

Man page for command dd previously had a portion since a long time, explaining how one could background the dd process & send sig USR1 to its pid & get current status.

The exact method had been explainded rather than just giving a hint as of now.

The wording were: (copied from still available on the web)
----------------------------------------------------------
Sending a USR1 signal to a running 'dd' process makes it print I/O statistics to standard error and then resume copying.

CW$ dd if=/dev/zero of=/dev/null& pid=$!

CW$ kill -USR1 $pid; sleep 1; kill $pid

18335302+0 records in
18335302+0 records out 9387674624 bytes (9.4 GB) copied, 34.6279 seconds, 271 MB/s
----------------------------------------------------------

Currently, it has been removed from the man page. It is a very useful tip which should IMHO remian in the man page.


Version-Release number of selected component (if applicable):
man 2.7.1
dd (coreutils) 8.24
4.2.5-300.fc23.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Pádraig Brady 2015-11-17 07:11:56 EST
The previous example was racy and could inadvertently kill the dd process.
http://git.sv.gnu.org/gitweb/?p=coreutils.git;a=commitdiff;h=v8.23-42-g27d2c73

A better slightly expanded example is within the info docs,
which the man pages now link to. Just click the link at
the bottom of man dd.

Note You need to log in before you can comment on or make changes to this bug.