Bug 1282765 - Update metadata dialog is empty
Update metadata dialog is empty
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: z3
: 7.0 (Kilo)
Assigned To: Matthias Runge
Ido Ovadia
: Triaged, ZStream
: 1289256 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 06:04 EST by Pablo Iranzo Gómez
Modified: 2018-02-08 06:05 EST (History)
9 users (show)

See Also:
Fixed In Version: python-django-horizon-2015.1.2-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 13:16:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OSP6 update metadata (129.46 KB, image/png)
2015-11-17 06:06 EST, Pablo Iranzo Gómez
no flags Details
OSP7 update metadata (101.22 KB, image/png)
2015-11-17 06:07 EST, Pablo Iranzo Gómez
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1476439 None None None Never
OpenStack gerrit 209108 None None None Never

  None (edit)
Description Pablo Iranzo Gómez 2015-11-17 06:04:35 EST
Description of problem:

Newly installed OSP environment, click on admin/flavors/select dropdown for one of them and click on update metadata.

Version-Release number of selected component (if applicable):


Actual results:

Empty dialog

Expected results:
Dialog for updating metadata
Comment 2 Pablo Iranzo Gómez 2015-11-17 06:06 EST
Created attachment 1095382 [details]
OSP6 update metadata
Comment 3 Pablo Iranzo Gómez 2015-11-17 06:07 EST
Created attachment 1095383 [details]
OSP7 update metadata
Comment 4 Pablo Iranzo Gómez 2015-11-17 06:07:56 EST
Package versions on this machine:

openstack-nova-console-2015.1.1-3.el7ost.noarch
openstack-swift-plugin-swift3-1.7-3.el7ost.noarch
openstack-packstack-puppet-2015.1-0.11.dev1589.g1d6372f.el7ost.noarch
openstack-cinder-2015.1.1-2.el7ost.noarch
openstack-dashboard-theme-2015.1.1-4.el7ost.noarch
openstack-swift-account-2.3.0-2.el7ost.noarch
openstack-heat-engine-2015.1.1-6.el7ost.noarch
openstack-ceilometer-alarm-2015.1.1-1.el7ost.noarch
openstack-nova-api-2015.1.1-3.el7ost.noarch
openstack-neutron-common-2015.1.1-7.el7ost.noarch
openstack-dashboard-2015.1.1-4.el7ost.noarch
openstack-swift-container-2.3.0-2.el7ost.noarch
openstack-heat-api-2015.1.1-6.el7ost.noarch
openstack-ceilometer-collector-2015.1.1-1.el7ost.noarch
openstack-nova-compute-2015.1.1-3.el7ost.noarch
openstack-nova-scheduler-2015.1.1-3.el7ost.noarch
openstack-neutron-2015.1.1-7.el7ost.noarch
openstack-neutron-openvswitch-2015.1.1-7.el7ost.noarch
redhat-access-plugin-openstack-7.0.0-0.el7ost.noarch
openstack-swift-object-2.3.0-2.el7ost.noarch
openstack-packstack-2015.1-0.11.dev1589.g1d6372f.el7ost.noarch
python-openstackclient-1.0.3-3.el7ost.noarch
openstack-keystone-2015.1.1-1.el7ost.noarch
openstack-utils-2014.2-1.el7ost.noarch
openstack-ceilometer-notification-2015.1.1-1.el7ost.noarch
openstack-ceilometer-central-2015.1.1-1.el7ost.noarch
openstack-ceilometer-compute-2015.1.1-1.el7ost.noarch
openstack-nova-cert-2015.1.1-3.el7ost.noarch
openstack-swift-2.3.0-2.el7ost.noarch
openstack-heat-common-2015.1.1-6.el7ost.noarch
openstack-ceilometer-api-2015.1.1-1.el7ost.noarch
openstack-selinux-0.6.37-1.el7ost.noarch
openstack-glance-2015.1.1-3.el7ost.noarch
openstack-ceilometer-common-2015.1.1-1.el7ost.noarch
openstack-nova-conductor-2015.1.1-3.el7ost.noarch
openstack-neutron-ml2-2015.1.1-7.el7ost.noarch
openstack-swift-proxy-2.3.0-2.el7ost.noarch
openstack-puppet-modules-2015.1.8-21.el7ost.noarch
openstack-nova-novncproxy-2015.1.1-3.el7ost.noarch
python-django-openstack-auth-1.2.0-5.el7ost.noarch
openstack-nova-common-2015.1.1-3.el7ost.noarch
Comment 6 Matthias Runge 2015-11-17 07:49:58 EST
how to test:

log into horizon as admin, go to admin/flavors
and click on one entry in the metadata column.

Without this patch, you'll get a nearly empty pop-up. Looking deeper, you'll get a 404 file-not-found error.

With the fix from this bug, you should see something like in https://bugzilla.redhat.com/attachment.cgi?id=1095382
Comment 10 Matthias Runge 2015-12-08 05:32:13 EST
*** Bug 1289256 has been marked as a duplicate of this bug. ***
Comment 13 Ido Ovadia 2015-12-20 04:25:35 EST
Verified
========
python-django-horizon-2015.1.2-4.el7ost.noarch

Note You need to log in before you can comment on or make changes to this bug.