Bug 1282877 - gcc-go: go.gcc - ar: `u' modifier ignored since `D' is the default (see `U')
gcc-go: go.gcc - ar: `u' modifier ignored since `D' is the default (see `U')
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 12:17 EST by Adam Miller
Modified: 2016-06-02 05:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-02 05:27:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Miller 2015-11-17 12:17:42 EST
Description of problem:
$ cat /tmp/hello.go 
package main

import (
        "fmt"
)

func main() {
        fmt.Println("Hello\n")
}

$ go.gcc run /tmp/foo.go
# command-line-arguments
ar: `u' modifier ignored since `D' is the default (see `U')
Hello

Version-Release number of selected component (if applicable):
gcc-go-5.1.1-4.fc22.x86_64

How reproducible:
Always

Additional info:
This appears to be related. https://github.com/golang/go/issues/12310
Comment 1 Jakub Jelinek 2015-12-08 07:00:22 EST
This is just binutils bug that it has been built in the way to ignore timestamps by default.  There is some rhbz on that.
Comment 2 Nick Clifton 2015-12-08 07:38:29 EST
(In reply to Jakub Jelinek from comment #1)

> This is just binutils bug that it has been built in the way to ignore
> timestamps by default.  There is some rhbz on that.

This is the one:

  https://bugzilla.redhat.com/show_bug.cgi?id=1124342


A workaround is to remove the 'u' option from the ar command line.  This is the change applied in the issue referenced in comment #1.


Note: the binutils rpm can be built without this behaviour enabled by editing the binutils.spec file and changing:

  %define enable_deterministic_archives 1

to:

  %define enable_deterministic_archives 0

However deterministic behaviour is required by some packages.
Comment 3 Adam Miller 2016-01-11 13:02:09 EST
If this is being tracked elsewhere for binutils, I don't mind closing this BZ unless there's any motivation to keep it open.

Note You need to log in before you can comment on or make changes to this bug.