Bug 1282882 - ntpdate-4.2.6p5-19.el7_1.3.x86_64 on rhel 6 not able to update
ntpdate-4.2.6p5-19.el7_1.3.x86_64 on rhel 6 not able to update
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.8
x86_64 All
unspecified Severity medium
: rc
: ---
Assigned To: Andrew Thomas
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 12:39 EST by Christian
Modified: 2017-03-24 10:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-24 10:15:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian 2015-11-17 12:39:25 EST
Description of problem:
Running a yum update on a new system results in uninstallable packages. After clearing out the bits that work with yum upgrade --skip-broken, yum now reports:

# yum upgrade
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package ntp.x86_64 0:4.2.6p5-2.el6_6 will be updated
---> Package ntp.x86_64 0:4.2.6p5-19.el7_1.3 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: ntp-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: ntp-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: systemd-units for package: ntp-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: systemd-units for package: ntp-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: systemd-units for package: ntp-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: ntp-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: libopts.so.25()(64bit) for package: ntp-4.2.6p5-19.el7_1.3.x86_64
---> Package ntpdate.x86_64 0:4.2.6p5-2.el6_6 will be updated
---> Package ntpdate.x86_64 0:4.2.6p5-19.el7_1.3 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.16)(64bit) for package: ntpdate-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: ntpdate-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: ntpdate-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: systemd-units for package: ntpdate-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: systemd-units for package: ntpdate-4.2.6p5-19.el7_1.3.x86_64
--> Processing Dependency: systemd-units for package: ntpdate-4.2.6p5-19.el7_1.3.x86_64
--> Finished Dependency Resolution
Error: Package: ntpdate-4.2.6p5-19.el7_1.3.x86_64 (EFH-RHEL_6_5-with-errata-x86_64)
           Requires: libc.so.6(GLIBC_2.16)(64bit)
Error: Package: ntp-4.2.6p5-19.el7_1.3.x86_64 (EFH-RHEL_6_5-with-errata-x86_64)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: ntpdate-4.2.6p5-19.el7_1.3.x86_64 (EFH-RHEL_6_5-with-errata-x86_64)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: ntp-4.2.6p5-19.el7_1.3.x86_64 (EFH-RHEL_6_5-with-errata-x86_64)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: ntp-4.2.6p5-19.el7_1.3.x86_64 (EFH-RHEL_6_5-with-errata-x86_64)
           Requires: systemd-units
Error: Package: ntp-4.2.6p5-19.el7_1.3.x86_64 (EFH-RHEL_6_5-with-errata-x86_64)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: ntpdate-4.2.6p5-19.el7_1.3.x86_64 (EFH-RHEL_6_5-with-errata-x86_64)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: ntp-4.2.6p5-19.el7_1.3.x86_64 (EFH-RHEL_6_5-with-errata-x86_64)
           Requires: libopts.so.25()(64bit)
Error: Package: ntpdate-4.2.6p5-19.el7_1.3.x86_64 (EFH-RHEL_6_5-with-errata-x86_64)
           Requires: systemd-units
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest




It appears the latest update of ntpdate has a dependency on the uninstallable systemd-units package for rhel6.
Comment 2 Miroslav Lichvar 2015-11-18 01:16:47 EST
ntpdate-4.2.6p5-19.el7_1.3 is a RHEL7.1 package, it can't be installed on RHEL6. It's not supposed to be in a RHEL6 channel.
Comment 3 Christian 2015-11-18 17:02:00 EST
(In reply to Miroslav Lichvar from comment #2)
> ntpdate-4.2.6p5-19.el7_1.3 is a RHEL7.1 package, it can't be installed on
> RHEL6. It's not supposed to be in a RHEL6 channel.

That's precisely my issue in that it appears in my RHEL 6 channel. Is there a way I can verify what channels my host is subscribed to?
Comment 5 Christian 2016-01-07 13:10:15 EST
It appears this has been fixed. If that's the case, this issue can be closed.
Comment 7 Dennis Gilmore 2017-03-24 10:15:27 EDT
This does not seem to be a problem currently. If you are still seeing this issue can you please reopen and provide full debug output from yum

Note You need to log in before you can comment on or make changes to this bug.