Bug 1282889 - Unable to filter package list items in UI
Unable to filter package list items in UI
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.1.4
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: satellite6-bugs
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 12:58 EST by Mike McCune
Modified: 2016-07-27 07:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:00:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (66.91 KB, image/png)
2015-11-17 12:58 EST, Mike McCune
no flags Details
package filtering ing 6.2.0-4.beta (64.42 KB, image/png)
2016-03-16 06:11 EDT, Ondřej Pražák
no flags Details
package filtering ing 6.2.0-4.beta, scoped search (56.72 KB, image/png)
2016-03-16 06:15 EDT, Ondřej Pražák
no flags Details
scoped search for life-cycle env (47.27 KB, image/png)
2016-05-25 09:22 EDT, Kedar Bidarkar
no flags Details
scoped search product repo (75.54 KB, image/png)
2016-05-25 09:23 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Mike McCune 2015-11-17 12:58:44 EST
Created attachment 1095578 [details]
screenshot

On various pages:

* Content -> Lifecycle Environments -> Environment -> Packages
* Content -> Products -> Repository Details -> Manage Packages

Any attempts to filter the list of packages results in a blank drop list where I would expect to see an auto-completed list of package names.
Comment 2 Ondřej Pražák 2016-03-16 06:11 EDT
Created attachment 1136949 [details]
package filtering ing 6.2.0-4.beta
Comment 3 Ondřej Pražák 2016-03-16 06:15 EDT
Created attachment 1136951 [details]
package filtering ing 6.2.0-4.beta, scoped search

Seems to be working ok in 6.2.0-4.beta, dropdown list is no longer empty and filter uses scoped search properly. Can anyone verify?
Comment 5 Brad Buckingham 2016-04-28 13:55:45 EDT
In Satellite 6.2 Beta Snap 9.2, I can confirm that both of the scenarios raised in the description have been converted to support scoped_search.  With that, the user will be presented with options and auto-complete is supported.

Moving this one ON_QA for verification.
Comment 6 Brad Buckingham 2016-04-28 14:22:44 EDT
Note: this bug is related to bug 1271661
Comment 7 Kedar Bidarkar 2016-05-25 09:17:38 EDT
scoped_search works fine now and the user will be presented with options and auto-complete is working.


VERIFIED with sat62-snap(GA)-12.1

will add 2 screenshots for the 2 pages with scoped search ( auto-complete )
Comment 8 Kedar Bidarkar 2016-05-25 09:22 EDT
Created attachment 1161424 [details]
scoped search for life-cycle env
Comment 9 Kedar Bidarkar 2016-05-25 09:23 EDT
Created attachment 1161425 [details]
scoped search product repo
Comment 10 Bryan Kearney 2016-07-27 07:00:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.