This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1282925 - Changing several bugs at once does not work for 100 or more bugzillas
Changing several bugs at once does not work for 100 or more bugzillas
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.4
Unspecified Unspecified
high Severity high with 1 vote (vote)
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
: Reopened
: 1277363 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 14:46 EST by Stanislav Ochotnicky
Modified: 2016-09-20 02:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-30 20:04:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Ochotnicky 2015-11-17 14:46:26 EST
Originally reported as
https://engineering.redhat.com/rt/Ticket/Display.html?id=375942

Changing a lot of bugs at once results on timeouts on Bugzilla proxy. This will be presumably fixed in Bugzilla 5.0 upgrade. This bug is to track this work and making sure we run our tests for that scenario.

Original text of the report:
Change several bugs at once Does not work.

Run a query, any query.
e.g. Net-serve-not-reviewed
<https://bugzilla.redhat.com/buglist.cgi?cmdtype=runnamed&namedcmd=Net-serve-not-reviewed>
query.
But any search is fine that will give you 100 BZ or more.

Click "Change Several bugs at once"
Click check all.

Try to do anything, simplest of things like add an email list to the CC
list.
Hit Commit

Bugzilla will not respond for several minutes and then
You will get

  Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request /POST /process_bug.cgi
<https://bugzilla.redhat.com/process_bug.cgi>/.

Reason: *Error reading from remote server*

------------------------------------------------------------------------
Apache Server at bugzilla.redhat.com Port 443

Kindly please fix this
IF you want me to show the problem to you, I can show it via Blue Jeans
session
No problem.

This problem has been there for at least 4 years.
So please do consider this as a high priority item.
Comment 1 Jason McDonald 2015-11-17 16:51:30 EST
Note that the bulk-update operation does complete successfully, despite the UI giving a proxy timeout.  That's why this issue hasn't received high priority in the past.
Comment 2 Stanislav Ochotnicky 2015-11-17 16:55:09 EST
I also want to reiterate - this is a user experience issue but does not actually affect the functionality. It's just ugly.
Comment 3 Rashid Khan 2015-11-17 17:10:15 EST
I would like to point out that most of the users do NOT know that the operation completed. How will they know? They just get a time out error 

Usually getting an error like "Operation Timeout, error" or something like that means the operation DID not complete. 


So no one is using this bulk changing feature because they think it errors out. 


Either take the feature out, or fix it. 
The current state of affairs is sub-optimal at best, awful at worst
Comment 4 Jeff Fearn 2016-01-13 02:03:20 EST
Moving this to sprint 48 as it requires QE, but it won;t be QE'able until we have a server behind a proxy with a timeout set.
Comment 5 Rashid Khan 2016-03-14 16:51:46 EDT
Any updates? 
Is it fixed now? 
When we will see it in production?

Silence is deafening. 

Almost 4 months without status update.
Comment 6 Rashid Khan 2016-03-14 16:51:47 EDT
Any updates? 
Is it fixed now? 
When we will see it in production?

Silence is deafening. 

Almost 4 months without status update.
Comment 7 Jeff Fearn 2016-03-14 18:45:50 EDT
This fix is part of Bugzilla 5 and will go in to production with the Bugzilla 5 upgrade. Currently Bugzilla 5 has gone to QE for it's first QE review, it'll probably need a few reviews to pass QE.

I do not have a date for the Bugzilla 5 upgrade.

Muhammad, where can people find the Bugzilla 5 schedule?
Comment 9 Jeff Fearn 2016-05-15 19:46:10 EDT
Moving this so it can be tested by QE, see https://bugzilla.redhat.com/show_bug.cgi?id=1328678#c6 for a suggestion on how to imitate an F5 layer.
Comment 10 Rony Gong 2016-05-18 00:53:04 EDT
Tested on
QA environment(5.0.2-rh7)
Result: Pass
Steps:
1. Install and config the squid in the qe server, start it
2. Config my firefox browser to using this proxy
3. Bach change 366 bugs, add 2 members to cc list, commit
==>It could return the batch update successful page after 6 minutes.
==>All bugs updated.
Comment 11 Rashid Khan 2016-05-30 19:57:41 EDT
Hi Jeff, 
Current release should mean the release that is available for users to use 

I just tried it with 268 BZs and I got this error. 

==========
Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request POST /process_bug.cgi.

Reason: Error reading from remote server

Apache Server at bugzilla.redhat.com Port 443

==============

Please do not close the BZ until it is really fixed. 
Thanks
Comment 12 Rashid Khan 2016-05-30 19:59:44 EDT
BTW, I do not think this BZ has anything to do with 1318898
As I can select all the 268 BZ in my querry. Yet I still get errors when I try to "change several bzs at once"
Comment 13 Jeff Fearn 2016-05-30 20:04:43 EDT
NEXTRELEASE is not CURRENTRELEASE, and it's the 5.x version of not the 4.x version, so it won't be in production until that server is migrated to the 5.x series.

It is not fixable in 4.x so it won't be addressed until the migration to the 5.x series.
Comment 14 Rashid Khan 2016-05-31 15:05:59 EDT
Have you verified that the bug is fixed with 5.x? 
Has anyone in the QA team verified that it is fixed with 5.x? 

If it is not verified that it is fixed, the why are you closing the bug? 


To me it seems like you are in a hurry to close the bug, way before it is available for users to use / try. 

When is 5.x going to be available ?
Comment 15 Jason McDonald 2016-05-31 16:06:18 EDT
(In reply to Rashid Khan from comment #14)
> Have you verified that the bug is fixed with 5.x? 
> Has anyone in the QA team verified that it is fixed with 5.x? 

Comment 10 shows that this item was verified by the Quality Engineer assigned to Bugzilla.

> To me it seems like you are in a hurry to close the bug, way before it is
> available for users to use / try. 

The bug satisfies the Bugzilla team's Definition of Done, so it makes sense to me that they closed it (and they did correctly mark it as NEXTRELEASE rather than CURRENTRELEASE).

The alternative would be to leave the bug sitting in VERIFIED until Bugzilla 5 is deployed.  In my opinion, setting the bug to CLOSED/NEXTRELEASE gives a clearer indication of the status than leaving the bug in VERIFIED for a potentially lengthy period.  The latter would create some uncertainty about whether the bug is planned for a release or has simply been forgotten.

Additionally, given the large number of bugs being fixed for BZ5, leaving them all in VERIFIED would clutter the backlog with a large number of items for which there is no more development or QE work to be done.

(Disclosure: I used to be the Product Owner for Bugzilla, but haven't worked on it since late-2015.  Now I'm just a keen observer.)
Comment 16 Jeff Fearn 2016-06-15 22:23:17 EDT
*** Bug 1277363 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.