Bug 1282938 - documentation around rbd_default_features [NEEDINFO]
documentation around rbd_default_features
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
1.3.0
All All
unspecified Severity low
: rc
: 1.3.2
Assigned To: John Wilkins
ceph-qe-bugs
: Documentation, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 15:30 EST by Sheldon Mustard
Modified: 2016-03-01 03:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 03:22:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tganguly: needinfo? (smustard)


Attachments (Terms of Use)

  None (edit)
Description Sheldon Mustard 2015-11-17 15:30:40 EST
Description of problem:

Can't find any documentation upstream and/or downstream, maybe I missed it. If it does exist need to find where it is.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 John Wilkins 2016-01-22 18:22:08 EST
I got quite a bit of info from Josh, and I've completely restructured the guide. I think their may be some need for formatting work on it though.

https://gitlab.cee.redhat.com/red-hat-ceph-storage-documentation/doc-Red_Hat_Ceph_Storage_1.3-Block_Devices/blob/v1.3/rbd-config-guide.adoc
Comment 3 John Wilkins 2016-01-25 12:35:05 EST
Fixed the formatting issue.
Comment 4 Tanay Ganguly 2016-02-04 04:20:24 EST
John,
I think the default rbd format is still 1 ( In document i am seeing default as 2)

#sudo rbd create Tanay-RBD/taa --size 9812

#sudo rbd -p Tanay-RBD --image taa info
rbd image 'taa':
        size 9812 MB in 2453 objects
        order 22 (4096 kB objects)
        block_name_prefix: rb.0.3fd4a7.238e1f29
        format: 1

rbd_default_format
Description
     The default format (2) if no other format is specified. Format 1 is the original format for a new image, which is compatible with all versions of librbd and the kernel module, but does not support newer features like cloning. Format 2 is supported by librbd and the kernel module since version 3.11 (except for striping). Format 2 adds support for cloning and is more easily extensible to allow more features in the future.
Type

    Integer
Default

    2
Comment 6 John Wilkins 2016-02-09 14:46:39 EST
I've verified that the default format is 1 for this release. It will be 2 in Infernalis and beyond. Be sure to revisit this matter in RHCS 2.0. 

https://gitlab.cee.redhat.com/red-hat-ceph-storage-documentation/doc-Red_Hat_Ceph_Storage_1.3-Block_Devices/commit/d1ccfefbdace699be485f121c9c865568c44b294
Comment 7 Tanay Ganguly 2016-02-10 06:12:52 EST
Marking this BUG as verified.

Sheldon,
If you are not happy with the content of the doc, please re-open this ticket.

Note You need to log in before you can comment on or make changes to this bug.