Bug 1283010 - The subcomponent value list should changed according to the component when changing bug's component
The subcomponent value list should changed according to the component when ch...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 22:00 EST by Rony Gong
Modified: 2015-12-15 21:13 EST (History)
5 users (show)

See Also:
Fixed In Version: 4.4.10045.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 21:13:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
component_subcomponent_capture (32.68 KB, image/png)
2015-11-19 20:35 EST, Rony Gong
no flags Details

  None (edit)
Description Rony Gong 2015-11-17 22:00:50 EST
Description of problem:
The subcomponent value list should changed according to the component when changing bug's component.


Version-Release number of selected component (if applicable):
4.4.10044-2

How reproducible:
Always

Steps to Reproduce:
1.Open a bug of 'RHEL 7' which component is kernel, then change it's component to other component which does not contain subcomponent
2.Open a bug of 'RHEL 7' which component is kernel, then change it's component to other component which contains subcomponent

Actual results:
No change happened to the subcomponent select box.

Expected results:
For step 1, the subcomponent select box should gone 
For step 2, the subcomponent select box values should changed according to new component 

Additional info:
Comment 1 Matt Tyson 2015-11-19 20:06:47 EST
I can't reproduce this.  Can you tell me what server it happened on and provide a screenshot of the problem?
Comment 2 Rony Gong 2015-11-19 20:33:53 EST
You can open below bug, login by your account of current production(maybe), then change it's component to lvm2(which contains subcomponent), or change to component bash(which doesn't contain subcomponent)
https://bzperfweb01.app.qa.eng.nay.redhat.com/show_bug.cgi?id=915335
Comment 3 Rony Gong 2015-11-19 20:35 EST
Created attachment 1096968 [details]
component_subcomponent_capture
Comment 4 Matt Tyson 2015-11-19 21:24:56 EST
I think this was caused by Bug 1281678.  Testing with the fix for that bug appears to fix this.

I'll leave this open but move to MODIFIED so it can be tracked for testing purposes.
Comment 5 Rony Gong 2015-11-22 21:52:46 EST
Tested on 
QA environment(bzperfweb01.app.qa) with version(4.4.10045-1, DB: psql)
Result: Pass
Comment 6 Rony Gong 2015-11-24 02:00:05 EST
@Matt,

Now, the only way to show the subcomponent list is click that inverted triangle icon. Previously(current production), I can list the subcomponent by clicking the subcomponent input box.
Comment 7 Rony Gong 2015-11-26 01:34:04 EST
(In reply to Rony Gong from comment #6)
> @Matt,
> 
> Now, the only way to show the subcomponent list is click that inverted
> triangle icon. Previously(current production), I can list the subcomponent
> by clicking the subcomponent input box.

This error also happened to select component in the enter bug page, like create an errata tools bug.
Comment 8 Rony Gong 2015-11-26 02:11:21 EST
please ignore comment 7, just focus on comment 6, QE will file a another bug to track component selection.
Comment 9 Rony Gong 2015-11-26 02:20:28 EST
(In reply to Rony Gong from comment #8)
> please ignore comment 7, just focus on comment 6, QE will file a another bug
> to track component selection.

https://bugzilla.redhat.com/show_bug.cgi?id=1285645
Comment 10 Hao Chang Yu 2015-11-26 21:53:29 EST
Hi Rony

I fixed 2 issues here.

1) Issue in comment 6.

2) In edit bug page, sub-component field sometimes not appear when a component with sub components is selected.

  Steps to test it:
  1) Pick a Red Hat Enterprise Linux 7, kernel bug.
  2) Change the product to other product that don't have sub components.
  3) Subcomponent field should disappear.
  4) Change the product back to RHEL 7 and component to kernel.

  Fixed issue:
  The subcomponents field should reappear.
Comment 11 Rony Gong 2015-11-29 20:52:54 EST
Tested on 
QA environment(bzperfweb01.app.qa) with version(4.4.10045-2, DB: psql)
Result: Pass
Comment 12 Matt Tyson 2015-12-15 21:13:45 EST
This change is now live. If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.