This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283052 - API server returns 503 on STG
API server returns 503 on STG
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Wesley Hearn
Jianwei Hou
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 00:44 EST by Liang Xia
Modified: 2017-05-31 14:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liang Xia 2015-11-18 00:44:49 EST
Description of problem:
Access API server entry point on STG, 503 returned

Version-Release number of selected component (if applicable):
STG(devenv-stage_1197)

How reproducible:
Always

Steps to Reproduce:
1.curl stg.openshift.redhat.com/broker/rest/api
BROKER=stg.openshift.redhat.com
curl -k -s -H "Accept:application/xml" -X GET https://$BROKER/broker/rest/api

Actual results:
<html><body><h1>503 Service Unavailable</h1>
No server is available to handle this request.
</body></html>

Expected results:
API entry point returned.

Additional info:
devenv-stage_1197 works fine.
Comment 1 Wesley Hearn 2015-11-18 10:04:12 EST
I have gone through and fixed it, was a simple thing of the brokers not having been reset. 

[0]deadbox:~ $ curl -k -s -H "Accept:application/xml" -X GET https://$BROKER/broker/rest/api
[10:03 AM] 
[6]deadbox:~ $ echo $?
6
Comment 3 Liang Xia 2015-11-18 21:23:20 EST
Verified it works now.
Comment 4 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.