Bug 1283064 - [heketi-cli] Durability option doesn't work
[heketi-cli] Durability option doesn't work
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Luis Pabón
Anush Shetty
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 02:22 EST by Anush Shetty
Modified: 2016-11-08 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 05:20:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2015-11-18 02:22:17 EST
Description of problem: Durability option for volume creation isn't working. 


Version-Release number of selected component (if applicable): heketi-1.0.1-1.el7rhgs.x86_64


How reproducible: Always


Steps to Reproduce:
1. To create a distribute volume, the durability option has to be set to none: heketi-cli volume create -size=100 -durabilty=none
2.
3.

Actual results: 

Volume creation process is not initiated at all.
Comment 2 Luis Pabón 2015-11-20 11:02:01 EST
Could you please provide error information and the logs, because I just tried it using the Heketi Demo, then upgraded to v1.0.1 and it worked.

[vagrant@storage0 heketi]$ ./heketi-cli volume create -size=100 -durability=none
Name: vol_47e3486674c1100da120565517071969
Size: 100
Id: 47e3486674c1100da120565517071969
Cluster Id: 76f6a4366bd678084b2cbe1c35135379
Mount: 192.168.10.101:vol_47e3486674c1100da120565517071969
Mount Options: backupvolfile-servers=192.168.10.100
Durability Type: none
Snapshot: Disabled

Bricks:
Id: 753b082c463502ddc480ffb90b31a7ae
Path: /var/lib/heketi/mounts/vg_1c4e5c7609c0df10c1b139c4225361e0/brick_753b082c463502ddc480ffb90b31a7ae/brick
Size (GiB): 50
Node: 36ae54ef1b01c22b62e406e4e2e94993
Device: 1c4e5c7609c0df10c1b139c4225361e0

Id: f14d01795eb1b1fdba40e08422e17875
Path: /var/lib/heketi/mounts/vg_bf861cd2a5f79a64f00b673e7fe0450c/brick_f14d01795eb1b1fdba40e08422e17875/brick
Size (GiB): 50
Node: 14309cde9f45bef8f1ec24d719008b20
Device: bf861cd2a5f79a64f00b673e7fe0450c
Comment 3 Luis Pabón 2015-11-20 11:02:29 EST
Could you please provide error information and the logs, because I just tried it using the Heketi Demo, then upgraded to v1.0.1 and it worked.
Comment 4 Anush Shetty 2015-11-24 05:20:04 EST
Apologies, typo in the command I used.

Note You need to log in before you can comment on or make changes to this bug.