Bug 1283265 - Failed to create Key Pair - ConnectionRefused
Failed to create Key Pair - ConnectionRefused
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
8.0 (Liberty)
x86_64 Linux
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
nlevinki
:
: 1283266 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 09:43 EST by Ido Ovadia
Modified: 2015-12-21 10:19 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 10:19:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ido Ovadia 2015-11-18 09:43:06 EST
Description of problem:
=======================
Creating a Key Pair failed due to  ERROR (ConnectionRefused)


Version-Release number of selected component:
=============================================
OSP Director 8 Beta
openstack-nova-scheduler-12.0.0-1.el7ost.noarch
openstack-nova-cert-12.0.0-1.el7ost.noarch
python-nova-12.0.0-1.el7ost.noarch
openstack-nova-common-12.0.0-1.el7ost.noarch
python-novaclient-2.30.1-1.el7ost.noarch
openstack-nova-compute-12.0.0-1.el7ost.noarch
openstack-nova-api-12.0.0-1.el7ost.noarch
openstack-nova-conductor-12.0.0-1.el7ost.noarch

How reproducible:
=================
100%


Steps to Reproduce:
===================
1. Deploy undercloud (OSP Director 8 Beta)
2. Deploy overcloud HA 
3. Create a key pair: nova keypair-add test_key_18_11

Actual results:
===============
ERROR (ConnectionRefused): Unable to establish connection to http://10.19.184.221:8774/v2/df4e3a5a9d8c4e48b39826228093f2bc/os-keypairs

Expected results:
================
Key pair created successfully


Additional info:
================
Failed in Horizon to
Comment 2 Dan Smith 2015-11-24 11:10:08 EST
This probably means something is very very broken. Is nova-api even running? Can you post server logs?

I expect this is some fundamentally broken deployment thing, so I expect we should move this over to the director folks.
Comment 3 Eoghan Glynn 2015-11-24 11:23:39 EST
*** Bug 1283266 has been marked as a duplicate of this bug. ***
Comment 4 Ido Ovadia 2015-12-13 03:59:51 EST
(In reply to Dan Smith from comment #2)
> This probably means something is very very broken. Is nova-api even running?
> Can you post server logs?
> 
> I expect this is some fundamentally broken deployment thing, so I expect we
> should move this over to the director folks.

The setup is not available. I will try to reproduce
Comment 5 Ido Ovadia 2015-12-21 10:19:31 EST
Not Reproduced
==============
openstack-nova-common-12.0.0-2.el7ost.noarch
openstack-nova-scheduler-12.0.0-2.el7ost.noarch
openstack-nova-conductor-12.0.0-2.el7ost.noarch
openstack-nova-cert-12.0.0-2.el7ost.noarch
python-novaclient-2.30.1-1.el7ost.noarch
python-nova-12.0.0-2.el7ost.noarch
openstack-nova-compute-12.0.0-2.el7ost.noarch
openstack-nova-api-12.0.0-2.el7ost.noarch
openstack-nova-novncproxy-12.0.0-2.el7ost.noarch
openstack-nova-console-12.0.0-2.el7ost.noarch

Note You need to log in before you can comment on or make changes to this bug.