Bug 1283271 - There is no difference between regular and bootable cinder image
There is no difference between regular and bootable cinder image
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0.2
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.2.0
: ---
Assigned To: Daniel Erez
Raz Tamir
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 10:00 EST by Eyal Shenitzky
Modified: 2017-02-28 11:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-28 11:32:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
vdsm+cinder+engine logs (1.10 MB, application/x-bzip)
2015-11-18 10:00 EST, Eyal Shenitzky
no flags Details

  None (edit)
Description Eyal Shenitzky 2015-11-18 10:00:51 EST
Created attachment 1096122 [details]
vdsm+cinder+engine logs

Description of problem:

When creating a cinder bootable disk the image create as regular disk,
But the disk appears in the engine as bootable. 

Version-Release number of selected component (if applicable):

engine - 3.6.0.3-0.1.el6
vdsm -4.17.10.1-0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:

1. Create bootable cinder disk

Run "cinder list" on the cinder external provider
to check results.


Actual results:
Disk appears as regular on cinder and as bootable on the engine.

Expected results:
Disk appears as bootable on cinder and on the engine.

Additional info:

Vdsm cinder and engine log attached
Comment 1 Daniel Erez 2015-11-18 15:58:27 EST
This issue is indeed a known gap found in early Cinder pre-integration phases. Bootable attribute can be set manually using the set-bootable command: https://blueprints.launchpad.net/cinder/+spec/add-bootable-option.

Since this flag has no real meaning or effect, merely stored in Cinder's DB; and the addition would require a change in openstack-java-sdk, marking as an RFE for 4.0 for reconsideration.

@Tal/Allon - can you please remove the ovirt-3.6.z flag request.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-18 15:58:31 EST
This bug is marked for z-stream, yet the milestone is for a major version, therefore the milestone has been reset.
Please set the correct milestone or drop the z stream flag.
Comment 3 Allon Mureinik 2016-01-20 12:12:38 EST
This isn't an RFE, it's a bug, at most.
Comment 4 Yaniv Kaul 2016-12-22 16:03:07 EST
(In reply to Daniel Erez from comment #1)
> This issue is indeed a known gap found in early Cinder pre-integration
> phases. Bootable attribute can be set manually using the set-bootable
> command: https://blueprints.launchpad.net/cinder/+spec/add-bootable-option.
> 
> Since this flag has no real meaning or effect, merely stored in Cinder's DB;
> and the addition would require a change in openstack-java-sdk, marking as an
> RFE for 4.0 for reconsideration.

Was it implemented in openstack-java-sdk?
Comment 5 Daniel Erez 2016-12-23 04:41:19 EST
(In reply to Yaniv Kaul from comment #4)
> (In reply to Daniel Erez from comment #1)
> > This issue is indeed a known gap found in early Cinder pre-integration
> > phases. Bootable attribute can be set manually using the set-bootable
> > command: https://blueprints.launchpad.net/cinder/+spec/add-bootable-option.
> > 
> > Since this flag has no real meaning or effect, merely stored in Cinder's DB;
> > and the addition would require a change in openstack-java-sdk, marking as an
> > RFE for 4.0 for reconsideration.
> 
> Was it implemented in openstack-java-sdk?

No, unfortunately the project hasn't been actively maintained for the last year:
https://github.com/woorea/openstack-java-sdk/issues/193
Comment 6 Daniel Erez 2017-02-28 11:32:20 EST
Since we don't release new versions of openstack-java-sdk, which is required to fix this issue (as explained in https://bugzilla.redhat.com/show_bug.cgi?id=1283271#c1). Closing for now.

Note You need to log in before you can comment on or make changes to this bug.