Bug 1283293 - internal compiler error: Segmentation fault
internal compiler error: Segmentation fault
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: avr-gcc (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thibault North
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 10:54 EST by Vincent S. Cojot
Modified: 2015-11-18 15:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 15:49:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
src.rpm (513.26 KB, application/x-rpm)
2015-11-18 10:55 EST, Vincent S. Cojot
no flags Details

  None (edit)
Description Vincent S. Cojot 2015-11-18 10:54:43 EST
Description of problem:

Trying to compile/rebuild mysql-connector-c++-1.1.6-1.fc23.src.rpm and I get this message:

/usr/include/c++/5.1.1/bits/stl_tree.h:1963:7: internal compiler error: Segmentation fault
       _Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::
       ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
test/unit/classes/CMakeFiles/test_preparedstatement.dir/build.make:65: recipe for target 'test/unit/classes/CMakeFiles/test_preparedstatement.dir/__/unit_fixture.cpp.o' failed

Version-Release number of selected component (if applicable):
gcc-c++-5.1.1-4.fc23.x86_64

How reproducible:

Always reproductible but not always at the same place:
A few minutes later I got:

DatabaseMetaDataTest::testSupportsConvert12()':
/export/home/vcojot/rpmbuild/BUILD/mysql-connector-c++-1.1.6/test/CJUnitTestsPort/compliance/DatabaseMetaDataTest.cpp:5986:1: internal compiler error: Segmentation fault
 }
 ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.

The bug is not reproducible, so it is likely a hardware or OS problem.
test/CJUnitTestsPort/CMakeFiles/CJUnitTestsPort.dir/build.make:209: recipe for target 'test/CJUnitTestsPort/CMakeFiles/CJUnitTestsPort.dir/compliance/DatabaseMetaDataTest.cpp.o' failed

Steps to Reproduce:
1. rpmbuild --rebuild ../SRPMS/mysql-connector-c++-1.1.6-1.fc23.src.rpm 

Actual results:

Fails to build

Expected results:

Should finish compiling and produce a working binary.. gcc shouldn't segfault.
Additional info:
Comment 1 Vincent S. Cojot 2015-11-18 10:55 EST
Created attachment 1096141 [details]
src.rpm
Comment 2 Vincent S. Cojot 2015-11-18 10:58:18 EST
In file included from /export/home/vcojot/rpmbuild/BUILD/mysql-connector-c++-1.1.6/test/driver_test.cpp:74:0:
/export/home/vcojot/rpmbuild/BUILD/mysql-connector-c++-1.1.6/test/test_common.cpp: In function 'int run_tests(int, const char**)':
/export/home/vcojot/rpmbuild/BUILD/mysql-connector-c++-1.1.6/test/test_common.cpp:3310:1: internal compiler error: Segmentation fault
 }
 ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
test/CMakeFiles/driver_test.dir/build.make:65: recipe for target 'test/CMakeFiles/driver_test.dir/driver_test.cpp.o' failed
Comment 3 Vincent S. Cojot 2015-11-18 11:39:34 EST
Please note I was able to build successfully with the following kernel:
inux skullcap 4.2.3-200.fc22.x86_64 #1 SMP Thu Oct 8 03:23:55 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

(yes, it's an fc22 kernel on my fc23 distro).

I'll be booting back into kernel-4.2.5-300.fc23.x86_64 to see if the issue comes back. I tested my RAM using the on-board Diagnostics (Lenovo W541) but no issue was found.
Regards,
Comment 4 Vincent S. Cojot 2015-11-18 15:49:06 EST
I cannot reproduce it anymore after reboot.. *sigh*
Closing as 'NOTABUG'

Note You need to log in before you can comment on or make changes to this bug.