Bug 1283380 - A warning "'webkitIndexedDB' is deprecated" is showed in console while using Chrome
A warning "'webkitIndexedDB' is deprecated" is showed in console while using ...
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Management Console (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Vu Dinh
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 15:44 EST by Vu Dinh
Modified: 2017-05-31 14:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IE11-HomePage (111.74 KB, image/png)
2015-11-24 02:07 EST, yapei
no flags Details
IE11-CreateApp (82.55 KB, image/png)
2015-11-24 02:08 EST, yapei
no flags Details

  None (edit)
Description Vu Dinh 2015-11-18 15:44:21 EST
Description of problem:
After logging into OpenShift Online, while using Management Console to create apps and etc in Chrome, a warning is showed "'webkitIndexedDB' is deprecated. Please use 'indexedDB' instead.".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in to OpenShift Online
2. Right-click on the website in Chrome and inspect element

Actual results:
'webkitIndexedDB' is deprecated. Please use 'indexedDB' instead.

Expected results:
None

Additional info:
This issue is due to outdated modernizr library (1.7) in origin-server/console/vendor/assets/javascripts/. I tested with the newer version 2.6.2 from github (https://github.com/Modernizr/v3.modernizr.com/tree/gh-pages/downloads) and the warning is no longer displayed.
Comment 2 yapei 2015-11-23 01:01:50 EST
Verified on fork_ami with actions:

1. Login to Openshift Online web console
2. Create ‘Ruby on Rails 4' application 
3. Check applications, settings, my account page

This warning is no longer displayed
Comment 4 yapei 2015-11-24 02:06:53 EST
Sorry I didn't get what you mean last time and thanks so much for your reminder, today I tested again on Firefox 41, Chrome 46, Safari 9, IE 11 about create applicaiton, add cartridges and delete application with developer tools opened

This warning "'webkitIndexedDB' is deprecated. Please use 'indexedDB' instead" is no longer displayed on any browser

But I have one thing to confirm, On IE 11, there are some error and warning info in console, I'm not sure whether it's acceptable or not, please help to check the attachment. 

Maybe these error and warning info are displayed  because Modernizr will detect javascripts, css , html formats and gives message when rules are not followed, just my opinion, please help correct.

Thanks very much.
Comment 5 yapei 2015-11-24 02:07 EST
Created attachment 1098009 [details]
IE11-HomePage
Comment 6 yapei 2015-11-24 02:08 EST
Created attachment 1098010 [details]
IE11-CreateApp
Comment 11 openshift-github-bot 2015-11-25 11:59:54 EST
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/a78ef6fc51aad0382e956a925e5f414df7477884
Bug 1283380 - A warning "'webkitIndexedDB' is deprecated" in console with Chrome

OpenShift Online console currently uses Modernizr JS library 1.7 which is
outdated and it causes a warning regarding deprecated webkitIndexedDB method
in Chrome browser.

This commit upgrades the modernizr library from 1.7 to 2.6.2 which will
eliminate the warning.

Bug 1283380
Link <https://bugzilla.redhat.com/show_bug.cgi?id=1283380>

Signed-off-by: Vu Dinh <vdinh@redhat.com>
Comment 12 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.