Bug 1283409 - Systems Administration Guide makes incorrect use of the term CIFS
Systems Administration Guide makes incorrect use of the term CIFS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-System_Administrators_Guide (Show other bugs)
7.0
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Maxim Svistunov
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 16:31 EST by Patrick Goetz
Modified: 2016-06-03 05:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-03 05:33:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Goetz 2015-11-18 16:31:42 EST
Document URL: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System_Administrators_Guide/index.html

Section Number and Name: Section 14.1 Samba

Describe the issue: 

The beginning of this section includes the following sentence regarding SMB:

"Modern versions of this protocol are also known as the common internet file system (CIFS) protocol"

Suggestions for improvement: 

This couldn't possibly be more wrong. CIFS is obsolete and was replaced long ago by SMB 2.0. In fact, SMB 2.0 is somewhat obsolete, having been replaced by SMB 3.0! CIFS is some old cruft from the 90's that no one supports any more.  Please delete this sentence entirely from the documentation.

The beginning of the following sentence: "It allows the networking of Microsoft Windows, Linux, UNIX, and other operating systems together" is also incorrect.  SMB is a file sharing *protocol* -- it's doesn't allow for any kind of "networking together".  That sentence is just awful.  Maybe try this instead:

"SMB allows Microsoft Windows, Linux, UNIX, and other operating systems to access files and printers shared from servers which support this protocol."

Additional information: 

  http://blog.varonis.com/the-difference-between-cifs-and-smb/
  http://blog.fosketts.net/2012/02/16/cifs-smb/
Comment 4 Maxim Svistunov 2015-12-10 11:18:29 EST
Hello Patrick,

Thank you for the report and for all the provided information.

I have implemented your feedback. Please compare the "before":

Samba is the standard open source Windows interoperability suite of programs for Linux. It implements the server message block (SMB) protocol. Modern versions of this protocol are also known as the common Internet file system (CIFS) protocol. It allows the networking of Microsoft Windows®, Linux, UNIX, and other operating systems together, enabling access to Windows-based file and printer shares. Samba's use of SMB allows it to appear as a Windows server to Windows clients.

and the "after":

Samba is the standard open source Windows interoperability suite of programs for Linux. It implements the server message block (SMB) protocol. SMB allows Microsoft Windows®, Linux, UNIX, and other operating systems to access files and printers shared from servers that support this protocol. Samba's use of SMB allows it to appear as a Windows server to Windows clients.

Does it look good now? If you think it does, I will set this bug to VERIFIED.

The change will appear at the customer portal soon - probably at the end of the next week.

Thanks again!
Comment 5 Patrick Goetz 2015-12-10 11:19:50 EST
Yes, this looks good.  Thanks!
Comment 6 Maxim Svistunov 2015-12-10 11:39:14 EST
Thanks a lot Patrick!

Please give more of your high-quality feedback should you have any!
Comment 7 Patrick Goetz 2015-12-10 11:48:30 EST
In reading through the documentation I've found quite a number of typos.  For example the word "configures" is repeated in the first paragraph on p. 9 of the Windows Integration Guide.  It's too much work to report each of these as a bug, but maybe I'll put them all into a single bug report, time permitting, since they're just typos and not actual factual errors.

Note You need to log in before you can comment on or make changes to this bug.