Bug 1283452 - systemd - renaming of journal-gateway subpackage results in failed updates
systemd - renaming of journal-gateway subpackage results in failed updates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 19:49 EST by Michal Jaegermann
Modified: 2015-12-06 23:14 EST (History)
7 users (show)

See Also:
Fixed In Version: systemd-228-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-06 23:14:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2015-11-18 19:49:04 EST
Description of problem:

On an attempt to update a rawhide installation the following happens:

--> Finished Dependency Resolution
Error: Package: systemd-journal-gateway-227-5.fc24.x86_64 (@rawhide)
           Requires: systemd(x86-64) = 227-5.fc24
           Removing: systemd-227-5.fc24.x86_64 (@rawhide)
               systemd(x86-64) = 227-5.fc24
           Updated By: systemd-227-7.fc24.x86_64 (rawhide)
               systemd(x86-64) = 227-7.fc24

Indeed a changelog for 227-7 has the following "Rename journal-gateway subpackage to journal-remote".  It looks like forgotten "provides" after this rename.

Version-Release number of selected component (if applicable):
systemd-227-7.fc24
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-20 10:05:37 EST
Botched rebase. Should be OK now.

Note You need to log in before you can comment on or make changes to this bug.