Bug 1283474 - network manager applet won't start after star-tup even it should
network manager applet won't start after star-tup even it should
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: plasma-systemsettings (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 23:43 EST by spochybo
Modified: 2015-11-24 09:18 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 09:18:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spochybo 2015-11-18 23:43:49 EST
With my Fedora22 that has KDE5, I am using the awesome window-manager. Since the updates on November 14th (update of systemsettings5 was part of it) I am encountering several problems, that seem to be connected to the loading of my systemsettings at the system-startup. The failure to load network manager applet is just one of them.

Further I cannot launch KDE applications like kshutdown or konsole, nor can I alter the startup/shutdown services (saying that KDED cannot be contacted), which results in not loading may Power Management profile.
Comment 1 Jirka Klimes 2015-11-24 03:44:55 EST
You are probably talking about KDE graphical frontend (plasma-nm), because nm-applet is not run in KDE by default.

https://wiki.archlinux.org/index.php/NetworkManager#Graphical_front-ends
Comment 2 spochybo 2015-11-24 04:02:07 EST
(In reply to Jirka Klimes from comment #1)
> You are probably talking about KDE graphical frontend (plasma-nm), because
> nm-applet is not run in KDE by default.
> 
> https://wiki.archlinux.org/index.php/NetworkManager#Graphical_front-ends

I am talking about nm-applet. I had it set to run at startup. However, this is not a problem anymore, and it seems to have been solved with a recent update (sometime last week). My systemsettings for the startup and shutdown services are now accessible and I do not get an error regarding KDED.

Anyway, I do not think that this was a problem with the applet in itself, but rather it had to do with the loading of the startup/shutdown settings at the beginning of a session. The problem is solved now.

Thanks, Sona
Comment 3 Rex Dieter 2015-11-24 09:18:42 EST
Fwiw, plasma5 only recently (re)gained support for classic xembed-based systemtray icons

Closing per "problem is solved now"

Note You need to log in before you can comment on or make changes to this bug.