Bug 1283515 - libvirt/virt-manager cannot start ppc vm with ide
libvirt/virt-manager cannot start ppc vm with ide
Status: CLOSED WORKSFORME
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
ppc All
unspecified Severity high
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 03:14 EST by Andy G
Modified: 2016-04-18 16:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 16:20:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy G 2015-11-19 03:14:08 EST
Description of problem:

Following an upgrade to qemu/virt-manager/libvirt courtesy of Debian, virt-manager is now no longer able to start PPC-based VMs.  The error message produced is "IDE controllers are unsupported for this QEMU binary or machine type".  This is, of course, not true since starting the VM by command line works absolutely fine.  The problem, I believe, is due to the commit to libvirt here:

http://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=eadd757

From the diff it seems that IDE controllers have been disabled except for intel 440fx chipsets.  Please can we also have an exception for ppc-beige-g3 architectures, which *only* support IDE.


Version-Release number of selected component (if applicable):

libvirt 1.2.20


How reproducible:

Always  


Steps to Reproduce:
1. Create a ppc beige-g3 vm in virt-manager
2. Attempt to start the vm

Actual results:

The error message "IDE controllers are unsupported for this QEMU binary or machine type"


Expected results:

The VM should start and run perfectly!


Additional info:

The host system is a x86_64 Core i7 system (don't have the exact spec to hand) but this should not be a factor.
Comment 1 Cole Robinson 2016-04-10 18:46:13 EDT
Please provide the VM XML you are using
Also can you grab /var/log/libvirt/qemu/$vmname.log from when it _was_ working? So we can see what config it was generating
Comment 2 Andy G 2016-04-18 16:20:55 EDT
Actually, I'd given you the commit where the regression occurred in my original post :o)

But, not to worry, it has been already fixed here:

http://libvirt.org/git/?p=libvirt.git;a=commit;h=e4ab3b5d

Sorry, I had forgotten about my report -- I should have closed it.
Comment 3 Cole Robinson 2016-04-18 16:53:34 EDT
Sorry I missed that. Thanks for following up

Note You need to log in before you can comment on or make changes to this bug.