Bug 128359 - Netstat truncating numeric IP addresses
Netstat truncating numeric IP addresses
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: net-tools (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-21 23:00 EDT by Mace Moneta
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 07:16:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2004-07-21 23:00:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040620

Description of problem:
When running 'netstat -n' the numeric IP addresses are truncated at 11
characters.

For example:

/bin/netstat -n | grep 8000
tcp        0  25840 ::ffff:135.82.8.13:8000 ::ffff:65.164.203.:2348
ESTABLISHED 
tcp        0  19040 ::ffff:135.82.8.13:8000 ::ffff:65.164.203.:2351
ESTABLISHED 

The addresses above should be '135.82.8.136:8000' and
'65.164.203.167:2348' for example.  In both cases, the address is
truncated at a length of 11 before being concatenated with the port
number (instead of a length of 15).

Version-Release number of selected component (if applicable):
net-tools-1.60-25.1

How reproducible:
Always

Steps to Reproduce:
1.Configure an IP address greater than length 11
2.netstat -n
3.observe truncation
    

Actual Results:  IP address is truncated at 11 characters

Expected Results:  Full IP address is displayed

Additional info:

Caused some in-house security scripts to malfunction, due to invalid
addresses.
Comment 1 Mace Moneta 2004-07-21 23:05:46 EDT
Also checked net-tools-1.60-29.i386.rpm in rawhide; same problem.
Comment 2 Radek Vokal 2004-08-31 07:16:13 EDT
Fixed in new rawhide net-tools-1.60-34
Comment 3 John Flanagan 2004-12-13 15:45:59 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-576.html
Comment 4 John Flanagan 2004-12-21 10:47:54 EST
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-535.html

Note You need to log in before you can comment on or make changes to this bug.