Bug 1283651 - Heat stack output value not escaped properly
Heat stack output value not escaped properly
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
low Severity low
: GA
: cfme-future
Assigned To: Dan Clarizio
Pavol Kotvan
ui:stack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 09:07 EST by Pavol Kotvan
Modified: 2017-08-21 09:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:05:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Heat template used for stack provisioning (2.20 KB, text/plain)
2015-11-19 09:07 EST, Pavol Kotvan
no flags Details
Screenshot - Stack output - 1 (54.38 KB, image/png)
2015-11-19 09:09 EST, Pavol Kotvan
no flags Details
Screenshot - Stack output - 2 (44.73 KB, image/png)
2015-11-19 09:09 EST, Pavol Kotvan
no flags Details

  None (edit)
Description Pavol Kotvan 2015-11-19 09:07:14 EST
Description of problem:
When reviewing output of created stack, in the value field, quotes are not escaped correctly. Screenshots of stack output are attached.

Version-Release number of selected component (if applicable):
5.5.0.11-rc1.20151117182049_653c0d4

How reproducible:
always

Steps to Reproduce:
1. Create Heat Stack  (yaml file attached)
2. Once stack is created, go to Cloud - Stacks
3. Click on stack which was created and in the Relationships table click on "Outputs"
4. 

Actual results:
Instead of quotes, "&quot" is displayed.

Expected results:
-

Additional info:
Heat stack provisioned against RHOS7-GA.
Comment 2 Pavol Kotvan 2015-11-19 09:07 EST
Created attachment 1096689 [details]
Heat template used for stack provisioning
Comment 3 Pavol Kotvan 2015-11-19 09:09 EST
Created attachment 1096690 [details]
Screenshot - Stack output - 1
Comment 4 Pavol Kotvan 2015-11-19 09:09 EST
Created attachment 1096691 [details]
Screenshot - Stack output - 2
Comment 5 Chris Pelland 2017-08-21 09:05:48 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.
Comment 6 Chris Pelland 2017-08-21 09:08:25 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.