Bug 1283662 - [host-update-manager] Info 'A new version is available...' visible even upgrade is in progress
[host-update-manager] Info 'A new version is available...' visible even upgra...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.0.2
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-3.6.2
: 3.6.2.5
Assigned To: Moti Asayag
Pavol Brilla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 09:24 EST by Jiri Belka
Modified: 2016-02-18 06:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:17:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.z?
rule-engine: planning_ack?
masayag: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51172 master MERGED webadmin: Hide 'Upgrade' action during host upgrade 2015-12-30 09:52 EST
oVirt gerrit 51178 ovirt-engine-3.6 MERGED webadmin: Hide 'Upgrade' action during host upgrade 2015-12-30 11:14 EST
oVirt gerrit 51180 ovirt-engine-3.6.2 MERGED webadmin: Hide 'Upgrade' action during host upgrade 2015-12-30 11:27 EST

  None (edit)
Description Jiri Belka 2015-11-19 09:24:50 EST
Description of problem:

Info 'A new version is available...' visible even upgrade is in progress.

It seems there is no tracking that 'Upgrade' button was clicked, ie. upgrade action later was successfully submitted, and thus info message 'A new version is available; an upgrade option will appear once the Host is moved to maintenance mode.' is still visible even there's ongoing upgrade in progress.

IMO the message should not be visible during upgrade process.

Version-Release number of selected component (if applicable):
rhevm-backend-3.6.0.3-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Host in Up state, msg in subtab: A new version is available.
   Upgrade
2. Click 'Upgrade' and confirm dialog.
3.

Actual results:
msg in subtab changes to:
"A new version is available; an upgrade option will appear once the Host is moved to maintenance mode" in states: Preparing to maintenance, Installing.
It is not anymore available during 'Reboot' state.

Expected results:
I doubt "A new version is available; an upgrade option will appear once the Host is moved to maintenance mode" makes sense at all after I clicked and submitted upgrade confirmation dialog. IMO the message either should not be there or should be tuned to something: 's/\([^;]*\).*/\1; an upgrade action was initialized./'

Additional info:
- "...moved to maintenance mode" - this is all automatic while clicking on Upgrade button, so please take into account this unlogic
Comment 1 Jiri Belka 2015-11-19 09:37:03 EST
There are also rumours that 'A new version is available. Upgrade' msg in subtab was not refreshed on time and a user was able to click on the link while there was an upgrade in progress and he got some traceback in UI. I was not able to reproduce...
Comment 2 Pavol Brilla 2016-01-21 11:31:27 EST
Verified
Comment 3 Pavol Brilla 2016-01-21 11:33:11 EST
Verified on 3.6.2.6-0.1.el6


A new version is available. <clickable> Upgrade </clickable>


"...moved to maintenance mode" excluded and all confusing messages disappered

Note You need to log in before you can comment on or make changes to this bug.