Bug 1283698 - frontend type is not being parsed
Summary: frontend type is not being parsed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmconf
Version: 23
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-19 15:45 UTC by Brian J. Murrell
Modified: 2015-12-07 20:28 UTC (History)
2 users (show)

Fixed In Version: rpmconf-1.0.14 rpmconf-1.0.16-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 20:28:31 UTC


Attachments (Terms of Use)

Description Brian J. Murrell 2015-11-19 15:45:24 UTC
Description of problem:
# rpmconf -d -frontend=gvimdiff -a
Configuration file '/etc/lightdm/lightdm.conf'
-rw-r--r--. 1 root root 5739 Aug 29  2014 /etc/lightdm/lightdm.conf
-rw-r--r--. 1 root root 6391 Oct  9  2014 /etc/lightdm/lightdm.conf.rpmnew

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      M     : merge configuration files
      Z     : background this process to examine the situation
      S     : skip this file
 The default action is to keep your current version.
*** aliases (Y/I/N/O/D/M/Z/S) [default=N] ? 
Your choice: m
ERROR:rpmconf:You did not selected any frontend for merge

Version-Release number of selected component (if applicable):
rpmconf-1.0.12-1.fc23.noarch

How reproducible:
100%, even using -ftype argument

Steps to Reproduce:
1. Pretty obvious I think

Actual results:
ERROR:rpmconf:You did not selected any frontend for merge


Expected results:
Should open gvimdiff to merge the files

Additional info:

Comment 1 Miroslav Suchý 2015-11-20 13:16:15 UTC
You used 
 -frontend=
while there should be
 --frontend=


I tried it (with the same version) and both
  rpmconf -a -fgvimdiff
and
  rpmconf -a --frontend=gvimdiff
works without problem and gvimdiff is started when I choose "M".

Comment 2 Brian J. Murrell 2015-11-20 13:33:55 UTC
While I will concede my erroneous use of "-frontend" the -ftype issue still remains:

$ man rpmconf
...
        [ -ftype --frontend=type ]
...
       -ftype, --frontend=type
              Define  which frontend should be used for merging. Valid options
              are: vimdiff, gvimdiff, diffuse, kdiff3, meld and env. When  set
              to  env,  the command to use is taken from the environment vari‐
              able $MERGE. The default is env.
...
$ rpmconf -ftype gvimdiff -a
usage: rpmconf [-h] [-a] [-c] [-d] [-D] [-f EDITOR] [-Z]
               [-o [PACKAGE [PACKAGE ...]]] [-v]
rpmconf: error: unrecognized arguments: gvimdiff

So a manpage discrepancy at least.

Comment 3 Miroslav Suchý 2015-11-22 11:05:01 UTC
Ahh. Type is placeholder. So it should be:
  rpmconf -fgvimdiff
and man page should have:
  -f<type>
so it is more clear.

Comment 4 Miroslav Suchý 2015-11-22 11:31:53 UTC
Fixed in commit:
  * 7ce2c50 (HEAD -> master, origin/master, origin/HEAD) 1283698 - clarify man page

Comment 5 Fedora Update System 2015-11-30 10:03:25 UTC
rpmconf-1.0.15-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd

Comment 6 Fedora Update System 2015-12-01 02:22:42 UTC
rpmconf-1.0.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmconf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd

Comment 7 Fedora Update System 2015-12-01 12:23:52 UTC
rpmconf-1.0.16-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd

Comment 8 Fedora Update System 2015-12-01 22:31:14 UTC
rpmconf-1.0.16-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmconf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd

Comment 9 Fedora Update System 2015-12-07 20:28:19 UTC
rpmconf-1.0.16-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.