Bug 1283713 - python3-enum34 should be removed from the distribution
python3-enum34 should be removed from the distribution
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-enum34 (Show other bugs)
24
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Robert Kuska
Fedora Extras Quality Assurance
:
Depends On: 1286457 1286458
Blocks: 1307911
  Show dependency treegraph
 
Reported: 2015-11-19 11:20 EST by Zbigniew Jędrzejewski-Szmek
Modified: 2016-04-18 06:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: python3-3.5.1-5.fc24 python-enum34-1.0.4-5.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 02:16:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2015-11-19 11:20:59 EST
Description of problem:
There is no point in packaging enum34 for python3.4 or especially python3.5.
That subpackage should be dropped.

To allow updates to existing installations, python3.{4,5}-libs should add
Provides/Obsoletes for python3-enum34.

Version-Release number of selected component (if applicable):
python-enum34 in F23 and F24
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-29 12:39:20 EST
There are only two users, which can be easily updated. But to remove the package from existing installations, python3.x-libs should still obsolete python3-enum34.
Comment 2 Jan Kurik 2016-02-24 10:32:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Zbigniew Jędrzejewski-Szmek 2016-02-25 08:19:12 EST
Thanks!

Note You need to log in before you can comment on or make changes to this bug.