Bug 1283754 - scriptlet errors during update/reinstall
scriptlet errors during update/reinstall
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 12:59 EST by Julian Sikorski
Modified: 2015-11-20 08:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 00:13:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2015-11-19 12:59:35 EST
Description of problem:
When I updated to rpcbind-0.2.3-0.3.fc22.x86_64 today, I was greeted by several scriptlet errors

Version-Release number of selected component (if applicable):
rpcbind-0.2.3-0.3.fc22.x86_64

How reproducible:
always

Steps to Reproduce:
1. dnf reinstall rpcbind

Actual results:
Failed to execute operation: File exists
warning: %triggerun(rpcbind-0.2.3-0.3.fc22.x86_64) scriptlet failed, exit status 1
Non-fatal <unknown> scriptlet failure in rpm package rpcbind
Non-fatal <unknown> scriptlet failure in rpm package rpcbind
Failed to execute operation: File exists
warning: %triggerun(rpcbind-0.2.3-0.3.fc22.x86_64) scriptlet failed, exit status 1
Non-fatal <unknown> scriptlet failure in rpm package rpcbind
Non-fatal <unknown> scriptlet failure in rpm package rpcbind
Failed to execute operation: File exists
warning: %triggerun(rpcbind-0.2.3-0.3.fc22.x86_64) scriptlet failed, exit status 1

Expected results:
No errors
Comment 1 Steve Dickson 2015-11-19 13:21:52 EST
(In reply to Julian Sikorski from comment #0)
> Description of problem:
> When I updated to rpcbind-0.2.3-0.3.fc22.x86_64 today, I was greeted by
> several scriptlet errors
> 
> Failed to execute operation: File exists
> warning: %triggerun(rpcbind-0.2.3-0.3.fc22.x86_64) scriptlet failed, exit
> status 1
> Non-fatal <unknown> scriptlet failure in rpm package rpcbind
> Non-fatal <unknown> scriptlet failure in rpm package rpcbind
> Failed to execute operation: File exists
> warning: %triggerun(rpcbind-0.2.3-0.3.fc22.x86_64) scriptlet failed, exit
> status 1
> Non-fatal <unknown> scriptlet failure in rpm package rpcbind
> Non-fatal <unknown> scriptlet failure in rpm package rpcbind
> Failed to execute operation: File exists
> warning: %triggerun(rpcbind-0.2.3-0.3.fc22.x86_64) scriptlet failed, exit
> status 1

This is very odd... There are two %triggerun in the spec file.

%triggerun -- rpcbind < 0.2.0-15
%{_bindir}/systemd-sysv-convert --save rpcbind >/dev/null 2>&1 ||:
/bin/systemctl --no-reload enable rpcbind.service >/dev/null 2>&1
/sbin/chkconfig --del rpcbind >/dev/null 2>&1 || :
/bin/systemctl try-restart rpcbind.service >/dev/null 2>&1 || :

%triggerun -- rpcbind > 0.2.2-2.0
/bin/systemctl enable rpcbind.socket

So the question is what did you upgrade from? Which trigger popped?
Comment 2 Julian Sikorski 2015-11-19 13:28:00 EST
I was upgrading from rpcbind-0.2.3-0.1.fc22.x86_64 however the bug can be triggered by reinstalling rpcbind-0.2.3-0.3.fc22.x86_64 as well.
How do i check which one popped?
Comment 3 Steve Dickson 2015-11-19 14:11:17 EST
(In reply to Julian Sikorski from comment #2)
> I was upgrading from rpcbind-0.2.3-0.1.fc22.x86_64 however the bug can be
> triggered by reinstalling rpcbind-0.2.3-0.3.fc22.x86_64 as well.
> How do i check which one popped?
I thinking its the second one... Is there a rpcbind.socket script?
Plus I'm not able to reproduce this
plete!
f22# dnf -y update rpcbind-0.2.3-0.3.fc22.x86_64.rpm
Last metadata expiration check performed 0:35:44 ago on Thu Nov 19 13:33:08 2015.
Dependencies resolved.
================================================================================
 Package        Arch          Version                 Repository           Size
================================================================================
Upgrading:
 rpcbind        x86_64        0.2.3-0.3.fc22          @commandline         62 k

Transaction Summary
================================================================================
Upgrade  1 Package

Total size: 62 k
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Upgrading   : rpcbind-0.2.3-0.3.fc22.x86_64                               1/2 
  Cleanup     : rpcbind-0.2.3-0.1.fc22.x86_64                               2/2 
  Verifying   : rpcbind-0.2.3-0.3.fc22.x86_64                               1/2 
  Verifying   : rpcbind-0.2.3-0.1.fc22.x86_64                               2/2 

Upgraded:
  rpcbind.x86_64 0.2.3-0.3.fc22                                                 

Complete!
Comment 4 Julian Sikorski 2015-11-19 14:16:19 EST
$ locate rpcbind.socket
/etc/systemd/system/sockets.target.wants/rpcbind.socket
/usr/lib/systemd/system/rpcbind.socket
Comment 5 Julian Sikorski 2015-11-19 14:22:42 EST
$ LANG=C sudo systemctl enable rpcbind.socket
Failed to execute operation: File exists
Comment 6 Steve Dickson 2015-11-19 14:27:06 EST
(In reply to Julian Sikorski from comment #5)
> $ LANG=C sudo systemctl enable rpcbind.socket
> Failed to execute operation: File exists
hmmm.. I'm not seeing that... 

# rpm -q rpcbind
rpcbind-0.2.3-0.3.fc22.x86_64
f22# systemctl enable rpcbind.socket
f22# 

Here is what my systemctl status  rpcbind.socket looks like:
f22# systemctl status  rpcbind.socket
* rpcbind.socket - RPCbind Server Activation Socket
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.socket; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2015-11-19 14:08:57 EST; 16min ago
   Listen: /var/run/rpcbind.sock (Stream)

Nov 19 14:08:57 f22.home.4dicksons.org systemd[1]: Listening on RPCbind Serve...
Nov 19 14:08:57 f22.home.4dicksons.org systemd[1]: Starting RPCbind Server Ac...
Hint: Some lines were ellipsized, use -l to show in full.

Does your look similar?
Comment 7 Julian Sikorski 2015-11-19 14:29:30 EST
$ sudo systemctl status rpcbind.socket
● rpcbind.socket - RPCbind Server Activation Socket
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.socket; enabled; vendor preset: disabled)
   Active: active (running) since czw 2015-11-19 19:25:15 CET; 1h 3min ago
   Listen: /var/run/rpcbind.sock (Stream)

lis 19 19:25:15 snowball2 systemd[1]: Listening on RPCbind Server Activation Socket.
lis 19 19:25:15 snowball2 systemd[1]: Starting RPCbind Server Activation Socket.
Comment 8 Steve Dickson 2015-11-19 15:07:35 EST
(In reply to Julian Sikorski from comment #7)
> $ sudo systemctl status rpcbind.socket
> ● rpcbind.socket - RPCbind Server Activation Socket
>    Loaded: loaded (/usr/lib/systemd/system/rpcbind.socket; enabled; vendor
> preset: disabled)
>    Active: active (running) since czw 2015-11-19 19:25:15 CET; 1h 3min ago
>    Listen: /var/run/rpcbind.sock (Stream)
> 
> lis 19 19:25:15 snowball2 systemd[1]: Listening on RPCbind Server Activation
> Socket.
> lis 19 19:25:15 snowball2 systemd[1]: Starting RPCbind Server Activation
> Socket.
This looks the same to me... IDK... big time... systemd is 
always so hard to debug...
Comment 9 Julian Sikorski 2015-11-20 00:13:48 EST
$ LANG=C sudo systemctl enable rpcbind.socket
Failed to execute operation: File exists
$ LANG=C sudo systemctl disable rpcbind.socket
Removed symlink /etc/systemd/system/sockets.target.wants/rpcbind.socket.
$ LANG=C sudo systemctl enable rpcbind.socket
Created symlink from /etc/systemd/system/sockets.target.wants/rpcbind.socket to /usr/lib/systemd/system/rpcbind.socket.
$ LANG=C sudo systemctl enable rpcbind.socket
$ LANG=C sudo systemctl enable rpcbind.socket
$

Interesting... Anyway, looks like it's gone now.
Comment 10 Steve Dickson 2015-11-20 08:35:29 EST
(In reply to Julian Sikorski from comment #9)
> $ LANG=C sudo systemctl enable rpcbind.socket
> Failed to execute operation: File exists
> $ LANG=C sudo systemctl disable rpcbind.socket
> Removed symlink /etc/systemd/system/sockets.target.wants/rpcbind.socket.
> $ LANG=C sudo systemctl enable rpcbind.socket
> Created symlink from /etc/systemd/system/sockets.target.wants/rpcbind.socket
> to /usr/lib/systemd/system/rpcbind.socket.
> $ LANG=C sudo systemctl enable rpcbind.socket
> $ LANG=C sudo systemctl enable rpcbind.socket
> $
> 
> Interesting... Anyway, looks like it's gone now.

WOW.. I'll make note of this... thanks!

Note You need to log in before you can comment on or make changes to this bug.