Bug 1283794 - PH not configuring properly
PH not configuring properly
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 16:58 EST by John Brines
Modified: 2016-08-30 05:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-30 05:05:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Brines 2015-11-19 16:58:02 EST
PHP doesn't seems to be working.

I have removed it and installed it. I have tried it with Apache and Cherokee and no matter what I do it doesn't work.

Recently with Cherokee I get service unavailable.
Comment 1 Remi Collet 2015-11-20 00:54:20 EST
Sorry, not enough information

Should work out of the box

- httpd + php
- httpd + php-fpm
- nginx + php-fpm
Comment 2 John Brines 2015-11-20 02:25:00 EST
(In reply to Remi Collet from comment #1)
> Sorry, not enough information
> 
> Should work out of the box
> 
> - httpd + php
> - httpd + php-fpm
> - nginx + php-fpm

Sorry about that.

I have tried

httpd + php
Cherokee + php and php-fpm and php-cgi

When I try to run in Cherokee http://localhost.info.php or say index.php it tries to open a file

In httpd it shows blank page or sometimes shows code.
Comment 3 Remi Collet 2015-11-20 02:26:54 EST
Sorry no idea.
WHat is the content of your test script ?
Comment 4 John Brines 2015-11-20 02:28:57 EST
(In reply to Remi Collet from comment #3)
> Sorry no idea.
> WHat is the content of your test script ?

<?php
phpinfo();
?>
Comment 5 John Brines 2015-11-21 04:48:49 EST
When I run the following it is clear PHP isn't working although it is installed

bash-4.3$ sudo ldconfig -p 2>/dev/null | grep -i php

bash-4.3$ ldconfig -p 2>/dev/null | grep -i php
bash-4.3$ echo -e "HEAD / HTTP/1.0\n" | nc localhost 80
HTTP/1.0 200 OK
Connection: close
Date: Sat, 21 Nov 2015 09:27:06 GMT
Server: Cherokee/1.2.104 (UNIX)
Last-Modified: Thu, 15 Oct 2015 15:20:30 GMT
Content-Type: text/html
Content-Length: 1795
Comment 6 John Brines 2015-12-01 03:11:55 EST
Hi Guys,

Any idea of why PHP isn't running but html is?

John.

Note You need to log in before you can comment on or make changes to this bug.