Bug 1283969 - Firefox prepopulates "Account username" of LDAP settings with normal user credentials
Firefox prepopulates "Account username" of LDAP settings with normal user cre...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 07:16 EST by Evgeni Golov
Modified: 2017-08-11 08:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-11 08:33:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 19519 None None None 2017-05-18 09:40 EDT

  None (edit)
Description Evgeni Golov 2015-11-20 07:16:06 EST
Description of problem:
Running Satellite 6.1.4 (but also reproduced this on 6.1.3) and Firefox 42.0.
Due to lazyness admin/changeme is saved as credentials for the Satellite URL in Firefox. When editing LDAP authentication, Firefox prepopulates the Account username field with "admin" (if the field is empty, as it is when LDAP allows anonymous bind).

Version-Release number of selected component (if applicable):
Satellite 6.1.4

How reproducible:
always

Steps to Reproduce:
1. save login credentials in firefox
2. go to Administer → LDAP authentication
3. create a new LDAP or edit an existing one that has an empty account username

Actual results:
account username is set to the stored satellite user by Firefox

Expected results:
account username is empty

Additional info:
Marking the field in LDAP settings as autocomplete="off" might help, but I did not test it.
Comment 1 Bryan Kearney 2016-07-26 15:09:49 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 2 Peter Gervase 2017-02-01 10:19:17 EST
This is still an issue in 6.2.6 satellite with firefox-51.0-3.fc26.x86_64
Comment 3 Sebastian Gräßl 2017-05-11 02:42:22 EDT
There is now an upstream issue for this http://projects.theforeman.org/issues/19519
Comment 6 Bryan Kearney 2017-08-11 08:33:37 EDT
This bz has been moved to an upstream issue. We will no longer be tracking this in the downstream. When the upstream issue is fixed, the next release of Satellite will include the fix. If this is a concern, please reach out to Bryan Kearney or Rich Jerrido. Thank you.

Note You need to log in before you can comment on or make changes to this bug.