Bug 1284013 - Ansible upgrade from 3.0.2 -> 3.1 fails due to deployment_type = enterprise
Ansible upgrade from 3.0.2 -> 3.1 fails due to deployment_type = enterprise
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 09:32 EST by Matthew Davis
Modified: 2015-11-21 16:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-21 16:54:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Davis 2015-11-20 09:32:04 EST
Description of problem:

In the 3.0 docs, deployment_type is set to 'enterprise'. However in 3.1, the ansible upgrade scripts expect deployment_type to be either origin or openshift-enterprise.

3.0 Ansible Install Doc - https://access.redhat.com/documentation/en/openshift-enterprise/3.0/installation-and-configuration/chapter-2-installing#advanced-installation

3.1 Ansible Install Doc - https://access.redhat.com/documentation/en/openshift-enterprise/3.1/installation-and-configuration/chapter-2-installing#advanced-installation


How reproducible:
Everytime


Suggestion: Include 'enterprise' in the ansible upgrade playbook.
Comment 1 Matthew Davis 2015-11-20 09:33:02 EST
Suggestion should have read:

Include 'enterprise' as an allowed deployment_type in the ansible upgrade playbook.
Comment 2 Scott Dodson 2015-11-20 09:56:43 EST
The switch from enterprise to 'openshift-enterprise' is mandatory when upgrading from 3.0 to 3.1 due to the significant change to how we deliver the product.

I've added an entry to the documentation mentioning that change is required when you use ansible directly.

https://github.com/openshift/openshift-docs/pull/1236

Note You need to log in before you can comment on or make changes to this bug.