Bug 1284051 - oc delete all *does not* really delete everything
oc delete all *does not* really delete everything
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 11:23 EST by Nicholas Nachefski
Modified: 2015-11-20 13:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 13:16:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicholas Nachefski 2015-11-20 11:23:51 EST
When running 'oc delete all -l app=smoketest' it deletes some objects, but apparently doesnt get them all.

atomic-openshift-master-3.1.0.4-1.git.4.b6c7cd2.el7aos.x86_64
atomic-openshift-node-3.1.0.4-1.git.4.b6c7cd2.el7aos.x86_64

[nick@desktop ~]$ oc delete all -l app=smoketest
replicationcontrollers/smoketest-1

[nick@desktop ~]$ oc delete all -l app=smoketest
No resources found

(wait 5 minutes, then do it again)

[nick@desktop ~]$ oc delete all -l app=smoketest
replicationcontrollers/smoketest-1


:-(

-Nick
Comment 1 Nicholas Nachefski 2015-11-20 12:09:17 EST
found the problem, i had an old 'oc' binary on my fedora box that was causing this.

Note You need to log in before you can comment on or make changes to this bug.