Bug 1284060 - errata tabs in webadmin only show the first 20 errata
errata tabs in webadmin only show the first 20 errata
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.1
: 3.6.1.1
Assigned To: Moti Asayag
movciari
:
: 1284061 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 11:47 EST by movciari
Modified: 2016-02-18 06:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:17:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
masayag: ovirt‑3.6.z?
rule-engine: planning_ack?
masayag: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49018 master MERGED engine: Use pagination when querying errata Never
oVirt gerrit 49019 ovirt-engine-3.6 MERGED engine: Use pagination when querying errata Never
oVirt gerrit 49141 refs/tags/ovirt-engine-3.6.1 ABANDONED engine: Use pagination when querying errata Never
oVirt gerrit 49200 ovirt-engine-3.6.1 MERGED engine: Use pagination when querying errata Never

  None (edit)
Description movciari 2015-11-20 11:47:48 EST
Description of problem:
katello API has pagination, only showing 20 errata per page, and errata tabs in webadmin only show the first page of errata for hosts/vms/engine that have more than 20 errata available

Version-Release number of selected component (if applicable):
10-34-60-182.rhev.lab.eng.brq.redhat.com

How reproducible:
always

Steps to Reproduce:
1. have a host with more than 20 errata available according to katello
2. check number of host errata in webadmin

Actual results:
total errata (security + bugs + enhancements) is only 20, which fits one page in katello api pagination

Expected results:
engine should check all the pages and show all available errata

Additional info:
Comment 2 Moti Asayag 2015-11-22 04:50:00 EST
In Katello 2.1, the request for host's errata returns the following for 
https://masayagello.usersys.redhat.com/katello/api/v2/systems/336d9859-2074-4321-a4c6-29d203d8d92d/errata
{
  "total": 165,
  "subtotal": 165,
  "page": null,
  "per_page": null,
  "search": null,
  "sort": {
    "by": null,
    "order": null
  },
 { list of the 165 errata }

In Satellite 6.1 , the request for host's errata returns the following for https://foreman.movciari.com/katello/api/v2/systems/b62d6bf5-377f-43a4-a1c1-c30bef382afa/errata
{
  "total": 77,
  "subtotal": 77,
  "page": 1,
  "per_page": 20,
  "search": null,
  "sort": {
    "by": null,
    "order": null
  },
 { list of 20 errata }

At some point Satellite changed the system behavior to use pagination with page=1 and per_page = 20, instead of letting the client decide if pagination is required or not.

The simplest approach is changing the url to end with "?per_page=99999" which is respected by Satellite and ignored by Katello 2.1.
Comment 3 Oved Ourfali 2015-11-25 03:50:42 EST
*** Bug 1284061 has been marked as a duplicate of this bug. ***
Comment 4 Sandro Bonazzola 2015-12-01 10:07:45 EST
This bug is referenced in git log for ovirt-engine-3.6.1.1.
Please set target release to 3.6.1.1 accordingly unless additional patches are needed.

Note You need to log in before you can comment on or make changes to this bug.