Bug 1284061 - errata tabs in webadmin only show the first 20 errata
errata tabs in webadmin only show the first 20 errata
Status: CLOSED DUPLICATE of bug 1284060
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.1
: ---
Assigned To: Moti Asayag
movciari
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 11:51 EST by movciari
Modified: 2016-02-10 14:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-25 03:50:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.z?
rule-engine: planning_ack?
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description movciari 2015-11-20 11:51:41 EST
Description of problem:
katello API has pagination, only showing 20 errata per page, and errata tabs in webadmin only show the first page of errata for hosts/vms/engine that have more than 20 errata available

Version-Release number of selected component (if applicable):
10-34-60-182.rhev.lab.eng.brq.redhat.com

How reproducible:
always

Steps to Reproduce:
1. have a host with more than 20 errata available according to katello
2. check number of host errata in webadmin

Actual results:
total errata (security + bugs + enhancements) is only 20, which fits one page in katello api pagination

Expected results:
engine should check all the pages and show all available errata

Additional info:
Comment 1 Oved Ourfali 2015-11-20 13:48:57 EST
What happens in the ovirt api? Do you see all errata or only 20?
Comment 2 movciari 2015-11-23 05:14:03 EST
There's only 20 in ovirt api, same as in webadmin.
Comment 3 Oved Ourfali 2015-11-25 03:50:42 EST

*** This bug has been marked as a duplicate of bug 1284060 ***

Note You need to log in before you can comment on or make changes to this bug.