Bug 1284093 - higher version "5.2.10-15.fc23" of package gutenprint-cups.x86_64 is already installed
higher version "5.2.10-15.fc23" of package gutenprint-cups.x86_64 is already ...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zdenek Dohnal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 14:50 EST by faldegast
Modified: 2016-12-20 11:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 11:08:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description faldegast 2015-11-20 14:50:34 EST
Description of problem:
HP printer drivers will not install.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Plug in printer
2. Wait until driver install dialog appear.
3. Click OK

Actual results:
The install dialog box suggests installing foomatic-4.0.11-10.fc22, gutenprint-cups-5.2.10.fc22 and hpijs-1:3.15.2-9.fc22.

"higher version "5.2.10-15.fc23" of package gutenprint-cups.x86_64 is already installed". 

And also hpijs isn't a package on FC 23.

Expected results:
The dialog should suggest drivers from FC23 and be able to install them.

Additional info:
It would be nice with some documentation on what the PNP printer driver install box is and how it pops up, so that one could figure out where the problem is. Like for example a "help" button within the dialogs. This apply to many many Fedora features. I chose kernel because the USB driver are the only software I'm decently sure is involved in this.

And oh I turned SELinux off so that's not the problem.
Comment 1 Josh Boyer 2015-11-20 15:00:09 EST
None if this is related to the kernel.
Comment 2 Tim Waugh 2015-11-26 03:55:34 EST
The packages that are suggested in the dialog box come from searching for packages providing drivers that match the IEEE 1284 Device ID from the device.

Jiri: could it be that the F23 packages are all missing the postscriptdriver(...) RPM tags?
Comment 3 Jiri Popelka 2015-11-26 05:33:23 EST
hplip & gutenprint look good to me, but foomatic & foomatic-db indeed lack them. I've made new foomatic & foomatic-db builds and we'll see if it helps.

Reporter, please try to get Device ID of your printer per
https://fedoraproject.org/wiki/How_to_debug_printing_problems#What_make_and_model_is_my_printer.3F
Comment 4 Fedora Update System 2015-11-26 06:55:42 EST
foomatic-db-4.0-49.20150819.fc23 foomatic-4.0.12-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-bc23c69657
Comment 5 Fedora Update System 2015-11-26 18:49:47 EST
foomatic-4.0.12-5.fc23, foomatic-db-4.0-49.20150819.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update foomatic foomatic-db'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-bc23c69657
Comment 6 Fedora Update System 2015-11-30 16:20:24 EST
foomatic-4.0.12-5.fc23, foomatic-db-4.0-49.20150819.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Admin XMLRPC Client 2016-06-24 06:37:25 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora End Of Life 2016-11-24 08:37:17 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2016-12-20 11:08:56 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.