Bug 1284094 - Dracut doesn't create an bootable system
Dracut doesn't create an bootable system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
22
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: dracut-maint-list
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 14:55 EST by Lars Bjorndal
Modified: 2015-11-24 06:30 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 03:05:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A boot log (46.62 KB, application/x-gzip)
2015-11-20 14:55 EST, Lars Bjorndal
no flags Details

  None (edit)
Description Lars Bjorndal 2015-11-20 14:55:51 EST
Created attachment 1097296 [details]
A boot log

Description of problem:
I upgraded from Fedora 21 to 22 using Yum distro-sync. After the upgrade the system wouldn't boot. After some fiddling I found that making an initramfs with dracut from Fedora 21 on the same system, I got a bootable system with the created initramfs. Booting with the wrongly created initramfs gives no shell for error probing and rescuing. Attached is a boot log where the problem is demonstrated, generated through a serial terminal. 


Version-Release number of selected component (if applicable):
041


How reproducible:
As a numerous of computers are installed with Fedora 22 and no one else has reported the problem there must be something wrong with my system, but I can't figure out what. 


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

The file/etc/dracut.conf isn't changed and has only commented lines. 

The attachment includes output from lsinitrb -k 4.1.10-100.fc21.x86_64, which points to a working initramfs. The file is called lsinitrb38.txt. 

The file lsinit -k 4.2.5-201fc22.x86_64, which is the wrongly created image file, is called lsinitrd41.txt.
Comment 1 Harald Hoyer 2015-11-23 04:44:01 EST
What is the output of:

# dracut --print-cmdline

??
Comment 2 Lars Bjorndal 2015-11-23 08:47:01 EST
'dracut --print-cmdline' gives:

 rd.lvm.lv=vg/root
  rd.lvm.lv=vg/swap
   rd.md.uuid=e2d8ba41:97283c86:3e04c0d7:793cd68e
  rd.md.uuid=c5d65afc:ad101
  b65:f6581c6e:7e83d868  resume=/dev/mapper/vg-swap
  root=/dev/mapper/vg-root
   rootflags=rw,relatime,data=ordered rootfstype=ext3
Comment 3 Harald Hoyer 2015-11-23 12:29:25 EST
try adding "rd.lvm.lv=vg/root rd.md.uuid=e2d8ba41:97283c86:3e04c0d7:793cd68e rd.md.uuid=c5d65afc:ad101b65:f6581c6e:7e83d868 " to your kernel cmdline and see, if that works
Comment 4 Lars Bjorndal 2015-11-23 14:50:08 EST
Yes, adding that to the /boot/grub2/grub.cfg made the system bootable.
Comment 5 Lars Bjorndal 2015-11-24 03:14:23 EST
Do you think adding some of the output from 'dracut --print-cmdline' is the right solution also for other systems that is to be updated in the same way? Why isn't the kernel parameters added automaticallay either by dracut or by grub2-mkconfig?
Comment 6 Harald Hoyer 2015-11-24 06:17:21 EST
(In reply to Lars Bjorndal from comment #5)
> Do you think adding some of the output from 'dracut --print-cmdline' is the
> right solution also for other systems that is to be updated in the same way?
> Why isn't the kernel parameters added automaticallay either by dracut or by
> grub2-mkconfig?

dracut does not know which bootloader you have

anaconda should have put those parameters on your kernel cmdline at installation time in the first place.

for grub2-mkconfig it would be dangerous trying to be smarter than the admin
Comment 7 Lars Bjorndal 2015-11-24 06:30:19 EST
Ok, thank you. I'm still a bit confused on why the system boots
normally without this additions to the kernel command line, if I use
dracut from Fedora 21 to create the initramfs.

Note You need to log in before you can comment on or make changes to this bug.