Bug 1284171 - ebook-viewer from calibre-2.42.0 crashes when it quits
ebook-viewer from calibre-2.42.0 crashes when it quits
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-21 08:13 EST by Pablo Rodríguez
Modified: 2016-12-05 13:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:30:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pablo Rodríguez 2015-11-21 08:13:36 EST
After updating calibre to version 2.42 in Fedora 22, ebook-viewer crashes each time it quits.

I tried to send the bug report with abrt, but I get the following error message:

--- Running report_uReport ---
The server at 'https://retrace.fedoraproject.org/faf' encountered an internal error (got error 500)
reporter-ureport failed with exit code 1
('report_uReport' exited with 1)

The steps to reproduce the crash on my computer are:

1. Either open an actual file or even a non-existing file, such as:

    ebook-viewer impossiblethatsuchthingexists

2. Press OK, if ebook-viewer complains about missing extension or non-existing file.

3. Quit ebook-viewer.

4. I get a segfault every time I quit.

I have compiled myself calibre-2.44.0 from koji and I get the same error.

BTW, at least version 2.44 seems to use dukpy (https://github.com/amol-/dukpy) to compile calibre. I wonder whether it could be added to koji.
Comment 1 Pablo Rodríguez 2015-11-21 08:20:20 EST
Sorry, Kevin, after more testing segfault seems to have vanished in ebook-viewer-2.44.0.

Just in case it helps.
Comment 2 Kevin Fenzi 2015-11-27 12:51:36 EST
Can you try this scratch build:

https://koji.fedoraproject.org/koji/taskinfo?taskID=11995734
Comment 3 Pablo Rodríguez 2015-12-01 12:18:58 EST
(In reply to Kevin Fenzi from comment #2)
> Can you try this scratch build:
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=11995734

It crashes, but abrt seems to know nothing about these segfaults.
Comment 4 Fedora End Of Life 2016-07-19 14:30:56 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 5 Hin-Tak Leung 2016-12-05 13:59:45 EST
Argh, still crashes, I just filed it under qt5-qtbase https://bugzilla.redhat.com/show_bug.cgi?id=1401638 - 

abrt do know about it.

$ abrt-cli list
id af670f9a51196aecb0c5149feb28045bca616c27
reason:         python2.7 killed by SIGSEGV
time:           Sun 04 Dec 2016 23:59:36 GMT
cmdline:        python2 /usr/bin/ebook-viewer '<edited-removed>.epub'
package:        calibre-2.69.0-1.fc25
uid:            1000 (Hin-Tak)
count:          2
Directory:      /var/spool/abrt/ccpp-2016-12-04-23:59:36-5583

Note You need to log in before you can comment on or make changes to this bug.