This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 128418 - df reports incorrectly on large nfs filesystems
df reports incorrectly on large nfs filesystems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: coreutils (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-22 13:58 EDT by Tony Davalos
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 00:32:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tony Davalos 2004-07-22 13:58:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Ran into a problem today when running df against a 5TB nfs filesystem

[test@host1]$ df -k .
Filesystem           1K-blocks      Used Available Use% Mounted on
disknode:/vol/vol0/bigfs
                     1231028224 -9223372036649330832 1436473200 
101% /tmpmnt/bigfs
[test@host1]$

Even though the filesystem reports incorrectly at 101% full, it is 
actually around 75% full and you can still write to the filesystem 
from the host that is reporting incorrectly.  I've tested this 
filesystem on both Solaris 8 and RHEL 3 x86_64 and both report 
correctly.

Version-Release number of selected component (if applicable):
coreutils-4.5.3-26

How reproducible:
Always

Steps to Reproduce:
1.cd to an nfs filesystem that is (probably) larger than 2TB
2.type df -k .
3.
    

Additional info:
Comment 1 Tim Waugh 2004-07-26 08:28:44 EDT

*** This bug has been marked as a duplicate of 126657 ***
Comment 2 John Flanagan 2004-09-02 00:32:08 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.