Bug 1284193 - [gtk3] gnome-terminal windows spuriously resized
[gtk3] gnome-terminal windows spuriously resized
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
: 1284263 1284523 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-21 15:04 EST by Joachim Frieben
Modified: 2015-12-22 13:00 EST (History)
6 users (show)

See Also:
Fixed In Version: gtk3-3.19.4-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-06 08:58:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2015-11-21 15:04:23 EST
Description of problem:
After today's updates which include GTK+ v3.19.2, gnome-terminal windows reduce their size whenever they obtain focus.

Version-Release number of selected component (if applicable):
gtk3-3.19.2-1.fc24

How reproducible:
Always

Steps to Reproduce:
1. Start GNOME session.
2. Launch gnome-terminal and an additional window.
3. Switch focus between the two windows.

Actual results:
The size of the gnome-terminal window reduces successively.

Expected results:
The size of the gnome-terminal window remains unaltered.

Additional info:
- Initial geometry is 26x76 which is also wrong.
- Reported behaviour occurs under both of Xorg and Xwayland.
Comment 1 Joachim Frieben 2015-11-29 05:09:40 EST
The size of gnome-terminal windows also gets reduced when typing while they are focused.
Comment 2 Andre Robatino 2015-12-03 15:17:01 EST
Bug 1284263 and bug 1284523 appear to be duplicates of this bug.
Comment 3 Adam Williamson 2015-12-04 17:04:09 EST
*** Bug 1284523 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2015-12-04 17:04:18 EST
*** Bug 1284263 has been marked as a duplicate of this bug. ***
Comment 5 Andre Robatino 2015-12-22 06:32:10 EST
gnome-terminal seems to be partly broken again, and I think it might have been the last gtk3 update (gtk-3.19.5-2.fc24 from Dec. 18). For example, "gnome-terminal --geometry=80x24" creates a window with the wrong size. Also, clicking on the lower right corner does not show the current size.
Comment 6 Joachim Frieben 2015-12-22 09:55:06 EST
(In reply to Andre Robatino from comment #5)
> Also, clicking on the lower right corner does not show the current size.

In a GNOME Wayland session, this is bug 1269097.
Comment 7 Andre Robatino 2015-12-22 13:00:02 EST
(In reply to Joachim Frieben from comment #6)
> (In reply to Andre Robatino from comment #5)
> > Also, clicking on the lower right corner does not show the current size.
> 
> In a GNOME Wayland session, this is bug 1269097.

Thanks - filed https://bugzilla.redhat.com/show_bug.cgi?id=1293671 for the other issue.

Note You need to log in before you can comment on or make changes to this bug.