Bug 1284197 - pvmove: "No data to move for ..." gives non-zero exit code
pvmove: "No data to move for ..." gives non-zero exit code
Status: CLOSED DUPLICATE of bug 1181121
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ondrej Kozina
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-21 16:07 EST by Andrey Utkin
Modified: 2015-11-23 05:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 05:21:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrey Utkin 2015-11-21 16:07:25 EST
Description of problem:
I am using such a command during LVM partition shrinking procedure.
pvmove --allocate anywhere /dev/X 

It gives "No data to move for ..." and returns non-zero code to shell. But the outcome is perfectly correct so that procedure can go forward. This should be fixed for successful scripting.

Version-Release number of selected component (if applicable):

sys-fs/lvm2-2.02.116-r2 (gentoo)
Comment 2 Ondrej Kozina 2015-11-23 04:24:27 EST
Hello Andrey,

I believe this is duplicate of bug 1181121. Could you elaborate your use case a bit or do you agree that the proposed solution in bug 1181121, comment 4 will work for you as well?
Comment 3 Andrey Utkin 2015-11-23 04:48:55 EST
Really a duplicate. So I am not alone surprised. Feel free to close this ticket.
Comment 4 Ondrej Kozina 2015-11-23 05:21:52 EST

*** This bug has been marked as a duplicate of bug 1181121 ***

Note You need to log in before you can comment on or make changes to this bug.