Bug 128422 - ccsd grabs config from network sliently if local config is invalid
Summary: ccsd grabs config from network sliently if local config is invalid
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: ccs   
(Show other bugs)
Version: 4
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-22 18:56 UTC by michael conrad tadpol tilstra
Modified: 2009-04-16 20:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-03 20:56:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description michael conrad tadpol tilstra 2004-07-22 18:56:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
ccsd grabs config from network sliently if local config is invalid.







Version-Release number of selected component (if applicable):
cvs head - Thu Jul 22 13:55:37 CDT 2004

How reproducible:
Always

Steps to Reproduce:
1. Have valid cluster.conf with running ccsd on other nodes in network.
2. put invalid xml cluster.conf on local node, 
3. start ccsd.
4. run ccs_test connect force

    

Actual Results:  ccsd will grab config from other node on network and
replace local config without giving any warning or reason.



Expected Results:  It would be nice for it to at the very least print
out a message saying that the local config is invalid and that it is
getting one from the network.

Additional info:

Comment 1 Kiersten (Kerri) Anderson 2004-11-04 15:08:21 UTC
Updates with the proper version and component name.

Comment 2 Kiersten (Kerri) Anderson 2004-11-04 15:17:33 UTC
Updates with the proper version and component name.

Comment 3 Kiersten (Kerri) Anderson 2004-11-04 15:21:13 UTC
Updates with the proper version and component name. Again, just love out tools.

Comment 4 Jonathan Earl Brassow 2004-12-21 21:32:23 UTC
ccsd will no-longer start up if the local copy is unparsable.  It will
display the results of the xmlParseFile() call and tell the user to
either correct the problem or (re)move the local conf and attempt to
grab a valid copy from the network.

Comment 5 Derek Anderson 2005-01-03 20:56:41 UTC
Ccsd is now doing what is described in comment #4.  Looks like this:

[root@link-12 /]# ccsd
/etc/cluster/cluster.conf:43: parser error : Opening and ending tag
mismatch: milton line 7 and cluster
</cluster>
          ^
/etc/cluster/cluster.conf:44: parser error : Premature end of data in
tag cluster line 2

^

Unable to parse /etc/cluster/cluster.conf.
You should either:
 1. Correct the XML mistakes, or
 2. (Re)move the file and attempt to grab a valid copy from the network.
[root@link-12 /]# echo $?
1
[root@link-12 /]# ccsd -V
ccsd DEVEL.1103743812 (built Dec 22 2004 13:31:24)


Note You need to log in before you can comment on or make changes to this bug.